New to Seafile and install process does not work


#1

I have followed the install process listed by your MANUAL MySQL. It does not work. Finally started install and let it use SQLite (which I really do not want to use). After running through several issues, I was able to start the seafile service. But unable to get it to work with Apache2. Why can’t the install process work? Also even though I have the ROOT pw, it fails to work as well. So at this time I have seafile installed (with pre-req) but still not useable. I am looking into this option as the issues with owncloud have pushed me away. I hope this group can provide a full set of instructions that work. I am willing to rebuild the server with fresh install as this is for testing only at this time. Installed on Ubuntu 16.04 LTS 64Bit.


#2

what error do you get?
Seafile is usually pretty straight forward to set-up


#3

The reason I decided to check out seafile is everything said it was easy to do and worked better than most options to sync file - which is all I want to do.

the error when I try to check status of service is
seafile.service - Seafile
Loaded: loaded (/etc/systemd/system/seafile.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-02-21 20:30:47 PST; 13h ago

Feb 21 20:30:47 cloud01 systemd[1]: Starting Seafile…
Feb 21 20:30:47 cloud01 seafile.sh[22593]: Seafile controller is already running, pid 21891
Feb 21 20:30:47 cloud01 systemd[1]: seafile.service: Control process exited, code=exited status=1
Feb 21 20:30:47 cloud01 systemd[1]: seafile.service: Failed with result ‘exit-code’.
Feb 21 20:30:47 cloud01 systemd[1]: Failed to start Seafile.

I have setup the systemd files as described online.

However, when I run the ./seafile.sh start [stop] processes are started or stopped. I still cannot get to the web ui either. I have setup apache2 per online instructions and verified apache2 is running.

I am not a linux admin but have used for many years and can do most every install and setup with instructions.

The instructions I followed are at
computingforgeeks_com/how-to-install-seafile-server-on-ubuntu-18-04-lts/
computingforgeeks_com/install-mariadb-10-on-ubuntu-18-04-and-centos-7/
manual.seafile_com/deploy/deploy_with_apache.html
I have not setup reverse-proxy yet and this might be the issue too.

Setup:
files located at /srv/seafile
seafile/seafile-server-latest symbolic link is correct and works.
Setup “seafile” user and group and all ownership for seafile folder is seafile

I hope this provides enough info in order to figure out what I did wrong.


#4

are you able to launch the server by using the seafile.sh? Check for any still runnnig seafile related processes before trying to start
If it does not work you should check the logs directory, there should be something on a log.


#5

Search for the community manual


#6

I have checked seafile.sh and when I attempt to start the process with ./seafile.sh start it states it is already running. I have checked apatch2 as well and it is running. I have looked through the logs that I know of and nothing provided found.


#7

What would I search for? I have already been searching and nothing is helpful. Everything says just install it and it works. This is not my personal experience at this time. Maybe I did something wrong but I followed the articles I listed. The only change I made was the folder name and location since it seemed there was NO REAL INSTALL process, just run the “setup…” file once you have copied the folder to the place you want to store the files. That is it. I have not setup reverse proxy as I want to keep it simple for troubleshooting process if needed. I used all of the default ports and attempted to open on the server which it is installed. About as simple as it gets.


#8

https://seafile.readthedocs.io/en/latest/

It is simple and it just runs. But you absolutely should use a reverse proxy.
The community manual will guide you through.


#9

I setup reverse proxy per instructions and still nothing works. I guess I will rebuild the server from scratch again and try one more time. If it fails again, then it is not a easy as stated. I am not a full Linux Admin but have been around it for many years and can navigate and manage it. On new items I follow the instructions to a T until I learn all of the configs, quirks, etc.