No access seafile from the internet (only local access)

I installed Seafile server (version 7.0.5 stable) by strictly following the installation procedure described in the first link given by Google with the request :


The installation process succeeded and I can access Seafile from on my local network from HTTP192.168.1.27

Then I would like to access from internet, not necessary from my local network.
My rpi3 can be accessed with a domain name “rpidomain” via no-ip. (I can access my rpi from the internet with : ssh rpidomain, so this domain is working).

Morever, I configure my nat so that it forwards the ports 8000,8082,80,433 (TCP/UDP) to the local address of my rpi.

if I can check that the port 8000 is open :
telnet rpidomain 8000
Trying ****…
Connected to rpidomain.

I get the same result with the port 8082

I changed the configuration file ccnet.conf where I set the
SERVICE_URL = HTTPrpidomain:8000
and in the web application, as admin I also changed the value of SERVICE_URL to the same value and the value of FILE_SERVER_ROOT to HTTP127.0.0.1:8000

With these settings I still can access locally via HTTP192.168.1.27 but not externally.

I think I have a problem with my nat configuration. I have to put values for destination port (it should be 8000) and external port. What are the external ports ? I wrote the same port values for both fields.

How can I debug, test my configuration ? Did the forwarding port configuration is set ?

ps: in this post, HTTP should be understood in lower case and followed by ://

Hey smilia,

I think FILE_SERVER_ROOT should be HTTPrpidomain:8082.

But why don’t you use a http server like nginx?
It should also work on raspbian and it handles all the stuff so you only have to forward one port. It also enables SSL.