Online media doesn't show

Hi guys.
I made a fresh install of Pro version (7.0.9) using the GitHub install guide: haiwen/seafile-server-installer, and I can’t see media content online.
I tried with Firefox and Chrome an the results are the same.

The media could not be loaded, either because the server or network failed or because the format is not supported.

This happen with videos or file music (I tried mp3, mp4, mov, webm, ogg…) and for PDF and Markdown files the file never ends to load.
(Even with Markdown files created online from Seafile)

Same behaviour on iOS app, except that the only thing I can see when I tried to play a file, is the SeaFile logo.

The only thing that seems to work is the Office and image viewer. I tried *.doc, *.docx, *.pptx, *.png, *.jpg, *.JPG, etc. and all they show properly only in web. Not in iOS app.

May be is some package missing in me Ubuntu 18.04 server?


I’ll answer myself, if somebody has the same problem in the future

You must configure in System Admin -> Settings your own SERVICE_URL and FILE_SERVER_ROOT.
For instance:

  • SERVICE_URL https : / / yourdomain . com
  • FILE_SERVER_ROOT https : / / yourdomain . com / seafhttp

(I added some spaces in the link for post purposes, please fill that with your domain/ip without spaces)

I hope this helps somebody else.