OnlyOffice blank page

Hi,
I have configured a Onlyoffice server for my Nextcloud instance by following this tutorial:

This server should be usable by Seafile for opening documents, but for some reason every document I open is just a blank page. I have no idea where to start looking for a problem…This guy had the same problem as me but he doesn’t have a definitive solution for my situtation:

Thanks in advance for the help.

Greetings

Post your Apache/nginx and seahub configuration. Check if you have valid SSL certificate if you using https.

1 Like

https://pastebin.com/k4WGLiNx

I don’t think this is a certificate problem tbh…

Here is example for onlyoffice on NGinx. I think you have problem with proxy pass setup for onlyoffice (some headers missing).

I can’t help you, not using NGinx but @Calby successfully setup onlyoffice on NGinx.

I’m using NGINX but I’m not using OnlyOffic.
I’ll start to install the online preview package soon, but then I’ll use libreoffice as I like that and every client that I’m administrating are using Libreoffice.

Oh sorry I mess it up. I wanted say @DerDanilo

2 Likes

Nginx just works fine. Had issues recently but got it solved with help of @holantomas.

As @holantomas said already, check your config again. If still not working revert to basic and keep adding your custom settings until it ain’t working anymore.

I used that config mentioned here above, this one, replaced backendserver-address with my address and added the right information for ssl_certificate and ssl_certificate_key. I still have a blank page…

Can I have a working NGINX file from you? I’ll start from there then.

Does the web-browse show any error? You can check the error, for example using Chrome, under “developer tools”.

Here is the example from the official OnlyOffice manual.

If you don’t know how to use the given examples, I suggest that you wait for the manual new we write. It might contain OnlyOffice examples.

We are working on the new manual, which consumes A LOT time from us. I expect it to be released right before christmas. Even though it won’t be entirely ready by then. We might release it for the sake of all the common errors that are done when setting up Seafile.

Sorry to not provide you with any other solution right now.

Problem fixed itself by reinstalling my OnlyOffice server.

Any idea what changed on the reinstall? Are you running OnlyOffice via Docker or standalone Linux installations? Do you have just the Document Server and/or Community Server and Mail Server too?

I’m running into the same problem with a 6.2.3 Seafile CE under Ubuntu 16.04.3 and Nginx and an OnlyOffice CE server (current release at the time of this post; Community+Document Servers) running under Docker in a separate subdomain.

Both servers work fine separately but I cannot get Seafile to open a document on the OO server. All I get are white/blank pages. I can go from OO to Seafile and open documents in the editor fine via WebDAV.

This document is suggestive of a solution but so far I am still getting white pages when I open Office documents.

Try to open browser developer panel a check console what error it’s saying. I got multple errors when try to install OO. Blank page in most of cases is mean document server running(cause it not response with 404 or 500) but there is some problem with JS like you have bad setup of proxy_pass so some resource files jako JS cannot (down)load. This errors are in console as 404(not found) or 403(forbidden) or 500 (server error).

Are using CSP? This can be problem too in bad VirtualHost configuration.

I have a working install Script (ugly bash) that sets up the whole OO machine on ubuntu including LE cert. When I have time I will publish the code on GitHub.
The setup is specialty written for Openstack but should also work on any server.

Please also check your Seafile logs on the server.

Standalone Document Server.

Thanks. I have a funny feeling that a standalone Document Server is the key.

I have a ticket opened at OO inquiring about it. I will post here with updates.

Try this (according to OO Tech Support):

/ds-vpath/web-apps/apps/api/documents/api.js

For example:

ONLYOFFICE_APIJS_URL = ‘https://oo.mydomain.com/ds-vpath/web-apps/apps/api/documents/api.js

in contrast to that given in the Seafile Manual

ONLYOFFICE_APIJS_URL = ‘https://oo.mydomain.com/web-apps/apps/api/documents/api.js

I’m going to double-back and see if I can build a standalone Document server that works with Seafile CE.

References for the reader:

https://manual.seafile.com/deploy/only_office.html

https://api.onlyoffice.com/editors/basic

1 Like

Check the following if you use NGINX. This also causes a blank page.

Before
add_header X-Frame-Options "SAMEORIGIN" always;

After
add_header X-Frame-Options "ALLOW-FROM https://sub.your-domain.de/" always;

Here is some magic. I cleaned the script up, quick and dirty. Writing config with bash is far from BP but it works.

Did not test the script after removing my stuff and putting variables so the config is easier. Please report any issue.

DO NOT USE ON A PRODUCTIVE SYSTEM. ONLY CLEAN MINIMAL INSTALL SERVERS!