OVH object storage - error when uploading


#21

@Jonathan Do you have an ETA for this ? Thank you


#22

In the latest pro beta there is a change relating swift [new] Support Swift v1 protocol.. I could imagine it fixes the problem, but cannot say for sure.


#23

Just tried the last pro beta but it doesn’t fix it.
Still got the same message:

[11/25/2017 01:06:55 AM] ../common/block-backend-swift.c(496): Put block xxxxx error 404. Response:
<html><h1>Not Found</h1><p>The resource could not be found.</p></html>
[11/25/2017 01:06:55 AM] ../common/fs-mgr.c(554): failed to commit chunk xxxxx.
[11/25/2017 01:06:55 AM] repo-op.c(1100): failed to index blocks

#24

Looks like this document has been updated. https://manual.seafile.com/deploy_pro/setup_with_swift.html

I don’t know if it is of help. Maybe it is.


#25

Thanks for the answer @shoeper
In fact, the added part in the docs is this:

Seafile also supports Tempauth and Swauth since professional edition 6.2.1. The auth_ver option should be set to v1.0, tenant and region are no longer needed.

Unfortunately the added v1.0 auth mechanism doesn’t help here. OVH only supports v2 and v3 Keystone API.


#26

@Jonathan Can we have at least some feedback on it please ? Do you confirm this is a bug on your side ?


#27

Yes, I’m still waiting for any news, bad or good !


#28

Sorry for this bug!
Option region now is not working in [block_backend], so seafile still uses first region in catalog, as @GNUletik said, OVH added a new region in the catalog which change its order, so we can’t visit the data in previous region.
We will fix this bug in the future, and then you can migrate data to the new region, but before this, we can’t solve it.


#29

Thank you @haikuo ! Do you have an ETA for this ?
Moving 80GB to other regions is not a viable solution as some changes can be made again on the region catalog


#30

Maybe you can then set the region to the one that contains your data and continue to use that region.


#31

That’s what we did, but as @haikuo said, the region is not working in the [block_backend] part.


#32

Maybe several weeks I’m not sure, and what Jonathan said is right, after fixing this you can choose the region which contains your data.


#33

Thanks for the feedback @haikuo!
I’ll wait for the fix :slight_smile:

I would also like to know if you are planning to support Keystone API v3?
I didn’t find any information on this in the forum.
For now, only the v2 is supported (changing v2.0 to v3.0 in seafile.conf throws an error).

However, the v2 is deprecated: https://developer.openstack.org/api-ref/identity/v2/
The v3 is the current version https://developer.openstack.org/api-ref/identity/v3/

This could lead to support to be removed for v2 API by cloud providers.
And then Seafile would stop working.


#34

We don’t have the plan for now, but we will consider it in the future if necessary.


#35

any workaround? i don’t see any issue in official repo, related to this problem


#36

@slav0nic No workarounds as far as I know.
Two new versions were released recently (see https://manual.seafile.com/changelog/changelog-for-seafile-professional-server.html).
So hopefully, it will be fixed soon.


#37

i know, still not fixed


#38

Ít is not “not fixed”. It has simply not been implemented. It is unsupported (so far).


#39

is here any issue on github related to this ‘feature’?


#40

@Jonathan @daniel.pan any updates on this? its getting annoying