“Page is not working error” when attempting to access http://127.0.0.1:8000

I opened the ccnet.config file from the seafile-server folder and changed http://127.0.0.1:8000/ to http://(my local ipv4 ip address):8000/ per manual instructions, saved the configuration file, and restarted the server as apart of the last steps in the windows setup portion of the manual. I then copy/pasted 127.0.0.1:8000 into the browser, however, instead of sending me to Seahub to log in, I recieve the error in the title above.

Manual: https://manual.seafile.com/deploy_windows/download_and_setup_seafile_windows_server.html
System Info: Windows 10 Enterprise 64-bit

Yeah, why have you changed it? Are you sure no firewall is running?

The Seafile manual says: Change the value of SERVICE_URL to http://:8000 in the config file, which I did. I temporarily disabled my firewall to test this to see if it was my Firewall to blame, typed http://127.0.0.1:8000/ in the browser and produced the same error:

This page isn’t working
127.0.0.1 didn’t send any data.
ERR_EMPTY_RESPONSE

Have you tried http://(your ip address):8000?

1 Like

I just noticed that you may be using the server for Windows. In that case, you can look for the IP address by doing this:

Right click the Charms Icon
Click Settings
Click Network & Internet
Click either Ethernet or WiFi, depending on how the computer is connecting to the network.
ipv4 Address will be what you are looking for

1 Like

Thanks for looking into this. Please note I’m running on a basic non-server Windows 10 Enterprise machine. After adding an admin account in Seafile Server, I completed the following steps from the setup manual:

(1) Right-click the tray icon and chose Open seafile-server folder.
(2) Opened file conf/ccnet.conf Change the value of SERVICE_URL to http://(my ipv4 address):8000 (the same Ipv4 address that appears when typing ipconfig into CMD)
(3) Saved changes made to the ccnet.config file in notepad > then I right-clicked the tray icon and choose Restart seafile
(4)Opened my Chrome browser and attempted to 127.0.0.1:8000 (Seahub)
(5)Received This page isn’t working error.

I understand that. I also understand that you are trying what the manual says, but keep in mind that the manual is outdated. I’m trying to determine if your problem is network related or not. 127.0.0.1 is a loopback address and it should respond. However, since it’s not, trying the ipv4 address from another machine, or even the same machine within the same network may give us more clues.

Also, can you post your Seafile config files and log files here? That may also give us a clue. Are you running behind a web server such as Apache or Nginx? What version of Seafile Server have you installed?

I don’t have access to another machine on the same network at the moment, but here’s what I could find:

(same machine) Results from CMD:

Pinging 127.0.0.1 with 32 bytes of data:
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Seafile Client Version: seafile-6.1.7-en
Seafile Server Version: seafile-server_6.0.7_win32.tar
Python Version: python-2.7.13

Attached are the recent Seafile Server logs (Sorry for the bad quality, had to convert to jpeg in order to upload)

Which log file is that? Seafile log or seahub log… It appears that seahub is continually restarting over and over.

These are server logs I believe. I found them in Path: C:\seafile-server\logs
the restarts may be from when I clicked Restart Seafile Server option everytime I retested 127.0.0.1:8000 in the browser.

The seahub log will give us a better clue. It’s what seems to be failing.

Would you know of the name/path of the Seahub log file? The only logfiles I can see from my end are those in the seafserv folder: ccnet, seafserv, seafserv-applet, and seafile

ccnet is the seahub log…

Oh okay, the server manual specified that the Seahub logs were named seahub_django_request.log so I had my eye out for that file. Thanks for clarifying though, hopefully updates are made to the manual to reflect the changes made in the current version.

Here’s the ccnet logfile text I located:


(again, sorry for the quality. zooming-in should magnify the text)

DJango is the interface with Python, and will very unlikely be the issue here, but it is possible. If it’s a Django problem, Seahub will let us know.

Unfortunately, though, I’m unable to read the logfile text, as it appears it was compressed. When I enlarge it, it is unreadable. you should be able to copy and paste it here.

Never mind my last comment. I downloaded the png file and was able to enlarge it. Is this the ccnet.log for the client or the server?

Other logs of interest:

seafile.init.log
controller.log
seahub.init.log

One other thought… Are you using NGinx or Apache by any chance? There are log files related to Seafile in the logs folder of one or the other. For example, the Nginx Seafile logs are located in /var/log/nginx and include the following log files of interest:

seahub.error.log
seahub.access.log

access.log may also be of use, which is different than seahub.error.log and seahub.access.log.

I believe ccnet.log is for the server, as it updates in size whenever I restart the Seafile Server or attempt to establish a session with it in the browser and its text indicates whenever a client is trying to connect. I’m currently not using Apache or Nginx. I ran a search in Microsoft Explorer against my C: Drive for the logs mentioned above and came up empty.

Is there a chance these logs have different names or are stored somewhere else? Would it be possible to create/edit a file to capture seahub logs?

I forget exactly where the server logs are stored in a Windows environment. I know where the client logs are located. There is a ccnet.log for the server and also one for the client. The one for the client is located under the logs folder of the ccnet folder located in the local user folder.

I’ll dig into this later tonight. I’m on a time crunch right now.