Photo upload doesn't start on Android

This is a copy of my thread I created in the Seafile GmbH forum but didn’t get any help. I got a reply this forum is the right place for my question :slight_smile:

I recently lost my camera pictures on my smartphone because my SD card broke

Fortunately I detected seafile can sync photos and I immediately configured my Android client according But upload doesn’t start.

Android: 4.3
Client: 2.1.3
Server: 5.1.3

I checked the logs on the server but didn’t detect any error messages. How can I get the upload to work?

Did you select the folder for uploading by yourself?
Or autoselect?
I am using Manuel folder selection.
So i also get WhatsApp / telegram etc. Pics and vids uploaded.

But i am on Android 6.

I tried it both ways: Manual and automatic.
I also tried to upload on my tablet running Android 4.4.2. Nothing is uploaded :frowning:

Seafile uses the Android syncing framework. You can try turn on auto-sync feature manually by “android system settings -> account -> third party accounts -> seafile -> sync now”.

Thank you very much Daniel ! This was a valuable hint. I frankly didn’t know Seafile uses the Android sync feature. When I checked the Seafile sync setting in the accounts page I detected sync was disabled for Seafile :-(. When I pushed the sync button Seafile sync started immediately.

Some investigations in the net finally pointed out I had sync disabled in Android in general. That’s why Seafile didn’t start syncing automatically. When I enabled sync in Android, Seafile now syncs my new pictures automatically and everything works like a charm now :-).

So this wasn’t an issue of Seafile. Instead it was a layer 8 issue :blush:

Thank you very much again for your help on this issue.