Problem with Shibboleth login on mobile clients

Hi,

we experienced problems with latest versions of mobile clients. We use Shibboleth for login and on Android devices it keeps returning error for wrong username or password and on iOS returns invalid server. It happens only when doing first login, if there’s a profile already on mobile it works. Is there a bug in mobile clients with Shibboleth login?

Please, help…

Ok, figured out. When specifying server address you have to ignore prefix that is already there so that line has to be like http://http(s)://server/.

Do your shibboleth servers use TLS log in? Without it is not supported anymore, afaik.

Yes, TLS logging is enabled.

Workaround with prefix works for iOS devices, but unfortunately not for Android… It happens with first login (very first or when profile is deleted). Any other idea what could be wrong?

Did it work before? There has recently been a change in the Shibboleth login of the Android app.

https://github.com/haiwen/seafile-client/pull/953

@egroeper

(by the way sorry for the bad language my last answer had. Don’t know what happened)

Yes, it did work before. Unfortunately I don’t know with which version problem occured (I don’t have Android)…

I’m asking around Android users to help me with pinpointing the problem. 3 users reported problem with wrong username/password, now another user tried and passed the login phase but app crashed when he clicked settings (different problem). I’m still collecting data. Maybe it’s a problem with Android patches (just guessing)… Everyone who tried has Seafile app version 2.1.16. I’m waiting to get info about their Android versions. I assume this fix was included in latest version of app.

The fix for the Android app hasn’t been merged yet:

https://github.com/haiwen/seadroid/pull/671

You referenced the PR for the desktop client.

By the way: For me Shibboleth login works fine (if we ignore possible http redirect problems on wrong user input).
Seadroid 2.1.16, Android 7.1.2

@sniexx: OS issue is a known bug in the recent version:
https://github.com/haiwen/seafile-iOS/issues/175

I’m a little bit happy, that we now aren’t the only ones complaining about it.

1 Like

Shibboleth login works for Android 4.4.4. and Android 7.0., it’s not working for Android 5.1.1., all of them use Seafile 2.1.16.

Today was update for iOS regarding Shibboleth login and it fixes problem. Anybody knows when we can expect update for Android? I don’t know what is with 5.1.1. that’s not working…

Also just checked iOS (2.6.8) and logging back in after token invalidation works without having to delete the account first.