Problems after changing IP address (Solved)

I have a Seafile 6.3.4 installation that has been running smoothly for several years on a home network. Today I made some changes to my network that meant the IP address for Seafile had to change. Since the change I cannot access Seafile/seahub but both are running and not reporting any errors.

I changed the ccnet.conf file so that SERVICE_URL = http://192.168.XX.XX:8000 where XX.XX are the new part of the IP address

I can access another application on http://192.168.XX.XX:6875.

My firewall allows access from 192.168.0.0/24 which is unchanged and I think is correct.

Seahub is still listening on port 8000 according to systemctl status seahub. However using nmap from another machine it only reports port 6875 in use.

I note that if you set SERVICE_URL via the Web UI it takes precedence. I wonder if a Web UI setting is taking precedence over my changed ccnet.conf file and if so how can I change it when I cannot access Seafile/seahub with a browser?

I would appreciate any suggestions to try to fix this

The SERVICE_URL only affect file downloading and uploading. If you can’t access the web site, it should be other problems.

It seems you were right but what happened does not make sense. I found a setting in

/etc/ssh/sshd_config

where I had limited ssh access to my-user@192.168.0.* but I was trying to access from an ip outside that range. After changing that things worked for a while. I could access from a browser and from two different iPhones which appeared to sync few hundred photos. I then went to change the settings on a desktop client and once again I could not access the server. Strangely I couldn’t access the server from the phones or a browser again.

I ran nmap again and got the following
PORT STATE SERVICE
8000/tcp filtered http-alt

Does this look right?

Ok this seems to be a classic firewall error. I thought a firewall rule of 192.168.0.0/24 meant any 192.168.XXX.XXX address. However it seems it means any 192.168.0.XXX address. I just had to replace the 0 with the correct number for my network. It doesn’t explain why my server was reachable on port 6875 for another app and not on 8000 for Seafile but at least it seems to be working now.