Problems on Mac: file didn't opens with Seafile client but opens with seadrive


we have got some users who have problems with Seafile user clients:

Context: users have:

  • Mac computer with Monterey 12.6.4,
  • Seafile client 9.0.0 or 9.0.1 (we don’t have so many users on Seafile… most use SeaDrive client)
  • Microsoft Office 2019 is up-to-date
  • Our Seafile server has been updated last Monday from 9.0.3 to 9.0.10

Some details from our diagnostic:

  • if the user click on a PowerPoint or Word file through Finder in a Seafile folder, nothing happen (icon react but didn’t open Microsoft Office apps). Sometime Microsoft Word or PowerPoint opened, but with a new empty file (no links with the file supposed to be opened!)
  • The user can open documents if he opens it through the Microsoft menu (file / Open a file…), then he finds it in the Seafile folder and then, it opens with a good content.
  • if users add one of these files into an Outlook email, the size of the file is 0 ko: image
  • this behavior didn’t happen
    • with Seadrive clients (of files inside seadrive folder)
    • with other files (local folders)
  • there is no difference between computer with M1 / M2 or Intel

Have you got a way to solve it?

Regards, Onésime

Hello @Onesime, does the word file you downloaded contain a special file name, and can other types of files with the same name be accessed normally? Is there any error output in seafile.log?


I Checked files, and there are these characters: é, è, - or _
Below some error message from the

[04/03/23 18:48:53] http-tx-mgr.c(785): libcurl failed to GET Couldn't resolve host name.
[04/03/23 18:49:03] sync-mgr.c(1653): File syncing protocol version on server is 2. Client file syncing protocol version is 2. Use version 2.

The second:

[04/06/23 21:14:24] http-tx-mgr.c(2384): Bad response code for GET 404.

[04/06/23 21:14:24] http-tx-mgr.c(2384): Bad response code for GET 404.

is that help you?

Hello, thanks for your feedback. This should be an encoding problem caused by a mac 13.3 upgrade. We’ll try to fix this issue.

Is there already a solution on the way? - the problem also happens on my Mac an is really annoying

1 Like

Hello, yes, apparently colleagues still gets some troubles…

1 Like

Hello, a new version will be released this week which includes a fix for this issue.

great, thank you!

has the new version been published? same issus here
thank you for your answer

… don‘t think so. 9.0.2 installed with still the same issue

1 Like

no reaction?

1 Like

Hello, I can confirm, that the error still exists.

1 Like


I can confirm that the bug is still exists. The problem is major, because it is not possible to
open documents from the seafile folder …

If a switch off, on the finder extension in the seafile client sometimes it works for one or two times …
the it stopps again …

#macos 13.1 #seafile 9.0.2

Hello, can you resync the library which includes files with special characters to a new directory using 9.0.2 ? If the server has not modified or renamed this file, the encoding of the synchronized file name will not change.

will the problem ever be solved? An update was announced last week… which never happened

1 Like

Did you try to resync the library (to a new folder)?
(As suggested by @feiniks)

Thanks for your answer.

What does that mean and how to proceed?

Thanks for your help

It seams that is bug in macOS 13.3 and 13.4 will be resolved:

  • Fixed a regression in macOS Ventura 13.3 where a security check causes bookmark resolution to fail when the path contains Unicode characters stored with composed normalization. As an example, this prevented files in Finder from opening when double-clicked. (107550080)
1 Like

Just download your problematic library into a new directory

Just installed macOS 13.4 and issue seems to be resolved. Files that was could’t be open by double-clicking, after update is opening fine.