Problems with installing Seafile and MySQL

Hi, everybody. There was a problem installing the SOFTWARE on the server. It is not possible to create a database with connecting and creating a database user… Here is an example:

Hi,

I ran into the same problem. Apparently mysql in newer versions stores the password of the users differently.

In order for it to work I changed that according to the notes further at the end of this article, to make a) the installation script work and b) make seafile able to open the database later.

ALTER USER ‘root’@‘localhost’ IDENTIFIED WITH caching_sha2_password BY ‘password’;
ALTER USER ‘seafile’@‘127.0.0.1’ IDENTIFIED WITH mysql_native_password BY ‘password’;

As you were able to verify the root during installation, you’d probably only have to change the password storage algorithm of your seafile user.

1 Like

On my web server I use ISPmanger Lite. There is a local MySQL server, version 10.3.22. there is an option, “IP addresses” and three choices, “From either” or from the other two others (I have two external IP addresses). When I select a specific one, it does not let me in with the error that it cannot establish a connection with the server. And if I choose “From Anyone”, then everything is installed normally, but this option does not suit me. How can this be solved?

@RoffDaniel did this also solve your problem? If yes then maybe it should be added to the seafile manual and/or the installer scripts…

Yes, my problem is solved with this =)

1 Like

@daniel.pan @rdb

Could you check that and amend a note to the seafile server manual and also fix setup-seafile-mysql.py accordingly, as Ubuntu 20.04 is listed as supported OS, but when trying to install it with the new Ubuntu bundled mysql version 8.0.20 this error occurs because mysql now per default stores the user pw either using pam acces control or as caching_sha2_password but seafile can’t access the DB like this.


Or best would be, if seafile could access the DB with the password stored as caching_sha2_password

Thanks for the notification.

We haven’t tested with MySQL 8.0 version yet. Currently the default database we use is MariaDB.

We will test with MySQL 8.0 later.

1 Like