Python2 dependencies messed up Seafile 7.0.5

Hi, I have problem on production server - Seahub returns 500, It probably points to messed up dependencies in Python. I have installed application several weeks ago but it is python3 in venv so it should not affect seafile. Error occurs on requests for “/” as well as posted “/api2/repos”
I have tried install urllib3 version 1.22 and 1.23 threough python2.7 -m pip install but did not help

System
Debian 10.4

currently installed:

python 2.7.16-1
python-setuptools 40.8.0-1
python-mysqldb 1.3.10-2
python-urllib3 1.24.1-1

Error:
[2020-07-27 12:14:36 +0000] [3169] [ERROR] Error handling request /api2/repos/
Traceback (most recent call last):
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/gunicorn-19.8.1-py2.7.egg/gunicorn/workers/sync.py”, line 135, in handle
self.handle_request(listener, req, client, addr)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/gunicorn-19.8.1-py2.7.egg/gunicorn/workers/sync.py”, line 176, in handle_request
respiter = self.wsgi(environ, resp.start_response)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/core/handlers/wsgi.py”, line 157, in call
response = self.get_response(request)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/core/handlers/base.py”, line 124, in get_response
response = self._middleware_chain(request)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/core/handlers/exception.py”, line 43, in inner
response = response_for_exception(request, exc)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/core/handlers/exception.py”, line 93, in response_for_exception
response = handle_uncaught_exception(request, get_resolver(get_urlconf()), sys.exc_info())
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/core/handlers/exception.py”, line 142, in handle_uncaught_exception
callback, param_dict = resolver.resolve_error_handler(500)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/urls/resolvers.py”, line 420, in resolve_error_handler
callback = getattr(self.urlconf_module, ‘handler%s’ % view_type, None)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/utils/functional.py”, line 35, in get
res = instance.dict[self.name] = self.func(instance)
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/urls/resolvers.py”, line 400, in urlconf_module
return import_module(self.urlconf_name)
File “/usr/lib/python2.7/importlib/init.py”, line 37, in import_module
import(name)
File “/storage/seafile/seafile-server-7.0.5/seahub/seahub/utils/rooturl.py”, line 41, in
url(r’^%s’ % settings.SITE_ROOT[1:], include(settings.SITE_ROOT_URLCONF)),
File “/storage/seafile/seafile-server-7.0.5/seahub/thirdpart/django/conf/urls/init.py”, line 50, in include
urlconf_module = import_module(urlconf_module)
File “/usr/lib/python2.7/importlib/init.py”, line 37, in import_module
import(name)
File “/storage/seafile/seafile-server-7.0.5/seahub/seahub/urls.py”, line 84, in
from seahub.api2.endpoints.user import User
File “/storage/seafile/seafile-server-7.0.5/seahub/seahub/api2/endpoints/user.py”, line 18, in
from seahub.settings import ENABLE_UPDATE_USER_INFO, ENABLE_USER_SET_CONTACT_EMAIL
ImportError: cannot import name ENABLE_UPDATE_USER_INFO

Thanks in advance

Well I found workaround - add ‘ENABLE_UPDATE_USER_INFO = False’ in conf/seahub_settings.py

however I was not able to see any differences around the point it started to fail. I investigated diffs of filesystem snapshots and there were no changes in application dataset so I think it has to be data related.

I would be glad If someone can explain the problem. I also tried to deploy clean docker installation but have not found suitable yaml file for 7.0.5. Newer versions failed on my data as well so I will probably need to update standalone version first and then migrate to docker to avoid dependency worries.

I need a sea file expert … sites https:// 166.62.45.19:8000 is down its blank I have back up help please

Welcome to the Seafile Community Forum.

You have an entire forum of Seafile experts at your disposal. Describe your problem and we’ll try to get your system back up an running. Please specify

  • your OS
  • your Seafile version and edition

and post relevant parts of

  • log and
  • conf files