RaspberryPi Changing Port Issues

Yes, I have 2 servers running so I decided to change the ports on one of my servers for my fiance to use so that he can manage his school files and keep them somewhere safe. Soi went on my Rasp (ArmServer) and changed the ports in the following file locations.
/Server/conf/ccnet.conf Port 8000 to 8001
/Server/conf/seafile.conf port 8002 to 8004.

After i have made the changes and start the server i get the following with an error.


Stopping seafile server …
[12/19/18 08:24:38] …/common/session.c(132): using config file /home/pi/Server/conf/ccnet.conf
Starting seafile server, please wait …
Seafile server started


Stopping seahub …
LC_ALL is not set in ENV, set to en_US.UTF-8
/home/pi/Server/seafile-server/seahub.sh: line 208: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or directory
Starting seahub at port 8000 …

Seahub is started


If someone could help me with this issue after it provides me with an error it starts on the normal ports. Also yes i have tried reinstalling it but it will not let me change the ports and keep them without simular issues.

After viewing the admin settings and looking at the service and file service ports the SERVICE_URL changed but the FILE_SERVER_ROOT port did not it is still set at “8082” and when i try to connect to the webpage via my port i set it to it will not connect to the page at all. It’s still using 8000.

Which Seafile Version? FastCGI or WSGI?

I’m using WSGI

Sorry for the late reply i’ve been getting back into college and havent had much time to work on it as much.