[Resolved] S3 Minio Memcache Error

s3

#1

Hello,

I am trying to setup Seafile Pro with Minio s3, but I keep running into memcache errors as follows:

seahub.log:

2018-12-01 11:56:24,751 [ERROR] django.pylibmc:146 set MemcachedError: error 47 from memcached_set: (0x55b74663ace0) SERVER HAS FAILED AND IS DISABLED UNTIL TIMED RETRY,  host: 127.0.0.1:11211 -> libmemcached/connect.cc:720
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/django_pylibmc/memcached.py", line 140, in set
    **COMPRESS_KWARGS)
ServerDown: error 47 from memcached_set: (0x55b74663ace0) SERVER HAS FAILED AND IS DISABLED UNTIL TIMED RETRY,  host: 127.0.0.1:11211 -> libmemcached/connect.cc:720

seafile.log:

[12/01/2018 11:49:35 AM] ../common/s3-client.c(818): [S3] libcurl failed to put seafile-block-objects:ad1964aa773125063ba7929b8f6adf6d7f914670: Send failed since rewinding of the data stream failed.
[12/01/2018 11:55:40 AM] ../common/obj-cache.c(106): Failed to set bdfa66b7-c498-441a-b3a7-0ac13e4538cc-26b30cd1b906ac4982cfd348edc761aa0020d70c to memcached: SERVER HAS FAILED AND IS DISABLED UNTIL TIMED RETRY.

seafile.conf:

[commit_object_backend]
name = s3
bucket = seafile-commit-objects
key_id = xx
key = xx
host = ca.s3.example.com
use_https = true
path_style_request = true
memcached_options = --SERVER=127.0.0.1 --POOL-MIN=10 --POOL-MAX=100

[fs_object_backend]
name = s3
bucket = seafile-fs-objects
key_id = xx
key = xx
host = ca.s3.example.com
path_style_request = true
memcached_options = --SERVER=127.0.0.1 --POOL-MIN=10 --POOL-MAX=100

[block_backend]
name = s3
bucket = seafile-block-objects
key_id = xx
key = xx
host = ca.s3.example.com
path_style_request = true
memcached_options = --SERVER=127.0.0.1 --POOL-MIN=10 --POOL-MAX=100

seahub_settings.py:

# Memcached Options
CACHES = {
    'default': {
#        'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache',
        'BACKEND': 'django_pylibmc.memcached.PyLibMCCache',
        'LOCATION': '127.0.0.1:11211',
    },
    'locmem': {
        'BACKEND': 'django.core.cache.backends.locmem.LocMemCache',
    },
}
COMPRESS_CACHE_BACKEND = 'locmem'

Any help would be appreciated,
Thanks


#2

have you checked that memcached is runnnig and binding to the correct address+port?


#3

Yes, and is running, first thing I checked, it’s not the issue. Forgot to mention that in the first message.


#4

Resolved the issue, was my own fault, I had forgot to put “use_https = true” under two of the blocks.