[RESOLVED] Seahub does not start after upgrade from 7.1.5 to 8.0.3

Debian server (Linux alpha 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2)

I have followed the upgrade notes:

    sudo apt-get install  default-libmysqlclient-dev 
    sudo pip3 install future mysqlclient

Stopped both seafhile and seahub serivices and then executed the seafile upgrade script:

    sudo upgrade_7.1_8.0.sh

which gave a positive outcome ("upgrade your seafile successfully)

Restarting the seafile service worked but when I tried to restart the service seahub I got this error:

Error happened during creating seafile admin

This was likely due to permission issues because after extracting the folder “seafile-server-8.0.3” it was still mistakenly owned by root. Changing this folder to the correct user and group ownership configured in seafile seemed to have resolved that problem… However:

Seahub still fails to start and just fails without telling more than:

Error:Seahub failed to start.
Please try to run "./seahub.sh start" again

The root cause of this problem was with the development library of the mysql client.
At least in debian 10 the following dependency (as indicated in the official instructions) causes the problem:

apt install default-libmysqlclient-dev

The command above installs the development library causing the issue. This shoul be replaced with:

apt install libmariadbclient-dev

This is confirmed by this other recent forum post: “cannot-start-seahub”

4 Likes

Good day. Use “bash seahub.sh start-fastcgi” to see the details of the error, or see “seafile-folder/logs/seahub.log