Router crashes when trying to sync

Hello guys, I hope you can help me.

I’m using the Seafile Server on a Banana Pi for some years now. Until now everything worked great, I used primarily the synchronization with several Windows Clients. At the moment I have the latest Windows Client and the latest Server for Raspberry Pi.

For a few weeks I’m using a new Windows PC, which I set up exactly as the others. With this PC I have a very annoying behavior, which I could not observe on other Clients. Every time I try to use the synchronization, either from Client to Server or from Server to Client, the router crashes and restarts. The Seafile Server is behind the following router: FRITZ!Box 6490 Cable. Does anyone have a similar issue and/or an idea how to solve this issue? Thanks in advance!

This should not happen under any circumstances. Contact AVM and ask them to fix the bug.

You don’t have to expect a soon solution, though. Did have contact with them because of a very nasty prioritization bug - took month until they fixed it. And before doing anything they told me to install their beta (labor) version. Restarted the whole router as soon as Any Connect VPN was launched. All in all the experience with their customer support was almost as bad as possible.

I had the same issue with my Raspberry. The only working solution I found was to limit the up- and download speed in every client. After switching from the Raspberry to a x64 system this problem disappeard.

Thank you very much, the speed limit seems to help!

@Jack: May I ask you which x64 system you choose?

Sure. It is a custom build system with

Intel® Pentium® G4400
32 GB DDR4
Samsung 950 Pro 256 GB (M.2) [system]
3x WD Red 1TB 2,5" as RAID5 [data]

with OpenMediaVault 3.0.64 as OS


I doubt that the type of server x86 or BananaPI has anything to do with it, i have a x86 server and i have a similar observations with a older Fritz!Box 6360 model. It does not crash, but internet connections will fail while syncing large amounts from inside the LAN.

If i use the dyndns domain in the seafile client the Fritz!Box has to route/forward all the packages from your public IP address to the Local IP address of your seafile server, rewriting each package in the process. When your client is also on the internal LAN these arrive at a speed it simply can not handle that fast.

As workaround for clients which aren’t mobile like desktops pcs you can simply use the internal hostname or IP address of the server in the seafile client. (you may have to set the ignore ssl error option to do so)

Then communication of server and client will work directly without involving the poor little Fritz!Box and sync goes at full speed of server/client.