Running on ARMv6

In the last days I have been trying to run the Seafile on my old Raspberry Pi Model B, with an ARMv6.

I tried the official docker image, but mariadb and seafile don’t seem have ARMv6 images. I tried other community docker image, also without success. I already tried build my Seafile binaries but the SeaHub just crash without any log after follow Deploying Seafile with MySQL guide.

At this moment I’m just tired and don’t know where to go, so I hope someone can tell me the best way to run Seafile Server on an ARMv6.

I think you should start here:

and here:

https://manual.seafile.com/deploy/

Hi, thanks for trying to help.

The GitHub’s releases page that you sent only have ARMv7 and ARMv8 builds. I’m using an ARMv6. I have also tried to build for my ARMv6 with their build script, and everything goes right.

So I followed to the other link that you also sent, and tried to deploy with MySQL. Everything seems go right, Seafile and Seahub started without any problems. But after a minute the Seahub process was always dying.

But with the help of @ChatDeBlofeld, on a Github issue I setted daemon variable to False in gunicorn.conf.py and find out the error.

ImportError: libopenjp2.so.7: cannot open shared object file: No such file or directory

I needed to install libopenjp2-7 on my Raspberry and everything runs without problems.

I don’t understand is why this package doesn’t come in the Seafile dependencies on the Deploy page.

So, for anyone who wants to run Seafile on an ARMv6 in the future and is having the same problems, try this:

Note: I installed Seafile on a fresh installation of Raspbian, with everything updated, but for some reason these packages were missing, I don’t know if is a ARMv6 problem, a Rapsberry problem or only my bad luck.

  1. Build Seafile in your Raspberry

  2. Install libopenjp2-7, this package is needed to run SeaHub, for the package Pillow - read this:

$ sudo apt install libopenjp2-7
  1. Install pymysql, if I not install it, the deploy script exit with an ModuleNotFoundError: No module named 'pymysql'
$ sudo pip3 install pymysql
  1. Deploy Seafile (in my case with MySQL), but instead install libmysqlclient-dev package, that doesn’t exist on Raspberry, install default-libmysqlclient-dev

5.1 For MariaDB Server I followed this post

5.2 For change the authentication plugin to mysql_native_password i followed this post

  1. Verify if Seafile and Seahub are running:
$ pgrep -f seafile-controller # checks seafile processes
$ pgrep -f "seahub" # checks seahub process

Access the Seahub 127.0.0.1:8000, or configure the reverse proxy.