SeaDrive 2.0.8 is released! Support for macOS 11

I have the same problem!!!

@Ehsan_Soodmand Did you try this?

Great. 2.0.9 works perfectly. Thanks.

@Jonathan SeaDrive 2.0.9 seems not to be compatible for Rosetta 2 and Apple’s new ARM processor.

[11/23/20 10:16:40] Not unmounting because rpc client not ready.
[11/23/20 10:16:40] failed to run "diskutil umount /Users/XXXXX/SeaDrive"
[11/23/20 10:16:40] [Daemon Mgr] stopping seadrive daemon
[11/23/20 10:16:58] start to install the helper tool
[11/23/20 10:16:58] got helper version: 0.1.0
[11/23/20 10:16:58] latest helper version is 0.1.0
[11/23/20 10:16:58] No need to reinstall the helper tool
[11/23/20 10:16:58] start to install/load the kernel driver
[11/23/20 10:16:58] error when kextInstall: KextManager failed to load with status: -603947007
[11/23/20 10:16:58] failed to install the kernel driverkext
[11/23/20 10:16:58] Exiting with error: Initialisieren nicht möglich: Der Kerneltreiber konnte nicht installiert werden
[11/23/20 10:17:00] Initialisieren nicht möglich: Der Kerneltreiber konnte nicht installiert werden
[11/23/20 10:17:00] app event loop exited with 1


If I try to manually load OSXFuse I get the following error:

Incompatible architecture: Binary is for x86_64, but needed arch arm64e

@poly01 We’ll need to update the osxfuse extension to 4.0 version, in order to support M1 processor. However this version is currently still in pre-release stage.

I have two users that always require a restart, again and again with version 2.0.9 and it does not work:

MacBook-Pro:~$ cd  /Library/Filesystems/osxfuse.fs/Contents/Extensions/11
MacBook-Pro:11$ sudo kextload   osxfuse.kext
Executing: /usr/bin/kmutil load -p /Library/Filesystems/osxfuse.fs/Contents/Extensions/11/osxfuse.kext
**Loading extension(s): com.github.osxfuse.filesystems.osxfuse requires a reboot**

@Jonathan Do you have some feedback for me?

I also have an M1 Mac. I tried installing macFUSE 4.0.4 (the renamed osxfuse) and loading the extension myself (rebooted into recovery mode, enabled extension, then loaded it via terminal). However, I get the same error when running SeaDrive 2.0.9:

Failed to intialize: failed to install kernel driver

So presumably there are hardcoded references to osxfuse in SeaDrive that need changing?

Yes SeaDrive will install its only copy of OSXFuse.

Hey Jonathan, is there any news on the windows explorer integration for SeaDrive? Creating a sharelink is currently not possible in SeaDrive. That’s the only feature missing right now. Thank you for the great software so far.

@Max2048 It’ll be added in the next version.

1 Like

Awesome to hear about that! Thank you very much Jonathan. :slight_smile: Sorry for asking, but can you give us an ETA of the next version?


Can you have a look at this issue:

It should be released this week.

1 Like

What error do you receive if you run SeaDrive from launcher? What error do you have in seadrive-gui.log?

Awesome to hear! That would be a great christmas present! Thank you Jonathan and the rest of the Seafile team.