[SeaDrive Bug]; Work-around after switching to https

When SeaDrive is installed while using http, and then the admin subsequently reconfigures the server to use https, SeaDrive operations fail with an I/O error. The reason for this behavior is because SeaDrive continues to try to use http rather than https. Changing the URL to https in the registry does not solve the problem.

Inspection of the accounts.db file located in the seadrive folder of the user’s folder (c:\users\username\seadrive) reveals that it still contains http rather than https.

The work-around is killing the seadrive-gui.exe and seadrive.exe processes in the task manager, then deleting the accounts.db file in seadrive, and finally restarting Seadrive. This will bring up prompt to reconfigure and relogin, which should solve the problem.

Assuming accounts.db has the same tables as the Seafile Client, you could also use this approach


1 Like

I had the same issue with Seafile client v7.0.10 on Windows. I know it’s not the latest release but it’s the one with the widest platforms support, so I had to choose it for my needs.

I had to uninstall the Seafile client to delete the profiles completely. Deleting from the app and recreating the profile led to the same error, the profile wasn’t fully deleted. Once I uninstalled, accepted to delete profiles, and reinstalled, then it worked flawlessly.