Seadrive does NOT EVER 'free up space'

If I pull a file from Seafile via Windows Explorer and then later select it and request to ‘free up space’, the file is instantly re-downloaded and marked with the green check mark again. Changing Windows storage settings (Settings|Storage|Configure Storage Sense…|Locally available cloud content|Seafile…) seems to have no impact. In short, these files are on stored locally and there isn’t anything I can do about it short of deleting Seadrive and manually deleting all traces then re-installing. However, after doing that the same issue recurs.

Any suggestions? This really makes Seadrive redundant to the regular Client and negates its main advantage over the Client (i.e. being able to remove files from the local machine when I’m done with them).

For reference, I’m using:

  • Windows 10 20H2
  • Seafile PRO (docker) 8.0.2
  • Seadrive 2.0.14
  • Seadrive local folder is fully excluded from A/V (ESET) and anti-malware (Malwarebytes) realtime scanning

Any ideas or help is appreciated.

Hey, Did you find a solution for this?
I’m having the same issue

No, and never heard back from anyone at Seafile either – pretty typical, to be honest. That’s a topic for another discussion…

Never figured out a workaround or anything and updates to Seadrive over the years still have not addressed this issue. Fortunately, however, it seems that the “Cache size limit” in Seadrive is respected so there isn’t a worry about downloading/caching a ton of stuff and running out of space locally. Seems that when that cache limit is reached, the oldest downloaded items are cleaned-up and returned to cloud-only status.

Hope that helps? Let me know if you find anything different, I’m still curious about this issue.

Hi I’m new to Seafile and just checking some of the issues to evaluate the software.

I’m using:

  • Windows 11 22H2
  • Seafile Pro (docker) latest
  • SeaDrive 2.0.26

I can’t reproduce the problem.
Storage gets freed as I would expect.
Maybe you can try again with the latest SeaDrive build.
I’m curious if this might be an issue isolated to Windows 10.

Cheers J

1 Like

My hack-around has been to not allow the Seafile client to not mange the files on any way; I forget the exact verbiage. I then on the client side there’s a couple related config toggles IIRC. Then I sync, do whatever I need - the. Physically delete them off my host, t I turn off letting my client manage files on the server.

I’ve realized that’s a problem somewhere that I don’t know yet. What I’ve noticed is, if I want to sync a folder I’d previously sync’d but have delete it - it doesn’t prompt me for a sync root location AND it doesn’t seem to recreate the file system structure in the original location; I meant to login/logout and see if that kicked anything to help sort this
:innocent: