Seadrive doesn't work on MacOS Ventura Beta

Hi everyone,
Recently I updated my MacBook Pro (M1) to MacOS 13.0 beta, then the Seadrive crashed with the error information shown in the figure
Screenshot 2022-10-04 at 23.32.01
It used to work well when I was using MacOS 12.6.
I checked the security configuration in recovery startup, which is same as before.
I also found that after this error occurred, the macfuse also crashed.

"macfuse.fs"is damaged and can’t be opened

So I checked the log in /Library/Logs/seadrive-helper.log, which is shown as follows

2022/10/05 14:55:22.888 Starting seadrive helper: 0.1.1
2022/10/05 14:55:22.896 Request: version({
2022/10/05 14:55:22.948 Request: kextInstall({
destination = “/Library/Filesystems/macfuse.fs”;
kextID = “io.macfuse.filesystems.macfuse”;
kextPath = “/Library/Filesystems/macfuse.fs/Contents/Extensions/11/macfuse.kext”;
source = “/private/var/folders/vz/0sgv0r_d01g2yt48sngdkd400000gn/T/AppTranslocation/5C389056-7237-4F9B-A162-ADD826F2D460/d/”;
2022/10/05 14:55:22.948 Kext loaded? 0
2022/10/05 14:55:23.032 Permissions for /Library/Filesystems/macfuse.fs/Contents/Resources/load_macfuse: 4755
2022/10/05 14:55:23.032 Loading kext path: /Library/Filesystems/macfuse.fs/Contents/Extensions/11/macfuse.kext
2022/10/05 14:55:24.700 setting macfuse admin group to osx admin group (group id = 36410528)
2022/10/05 14:58:25.117 Starting seadrive helper: 0.1.1
2022/10/05 14:58:25.148 Request: version({
2022/10/05 14:58:25.207 Request: kextInstall({
destination = “/Library/Filesystems/macfuse.fs”;
kextID = “io.macfuse.filesystems.macfuse”;
kextPath = “/Library/Filesystems/macfuse.fs/Contents/Extensions/11/macfuse.kext”;
source = “/private/var/folders/vz/0sgv0r_d01g2yt48sngdkd400000gn/T/AppTranslocation/28B5596B-2922-4E27-8F6F-C9CF6F51D22A/d/”;
2022/10/05 14:58:25.211 Kext loaded? 0
2022/10/05 14:58:25.339 Permissions for /Library/Filesystems/macfuse.fs/Contents/Resources/load_macfuse: 4755
2022/10/05 14:58:25.339 Loading kext path: /Library/Filesystems/macfuse.fs/Contents/Extensions/11/macfuse.kext
2022/10/05 14:58:26.419 setting macfuse admin group to osx admin group (group id = 65120288)

Many thanks to have your suggestions.

I’ve solved it now.
I found that when installing Seadrive, it will install a macfuse for you, whose version is 4.2.1. This version somehow cannot work on MacOS Ventura, hence the error occurs.
My solution is, after the Seadrive installed, remove the macfuse 4.2.1 manually (the path is /Library/Filesystems/macfuse.fs), and install a 4.4.1 to replace it, then the Seadrive works :slight_smile:

1 Like

We’ll upgrade SeaDrive 2.0 to use latest macfuse.

Note that the kernel extension will be unnecessary in the future. We’re now working 3.0 version of SeaDrive which uses file provider API from macOS. But until 3.0 is production ready, we’ll still maintain 2.0 version.

1 Like

got it, thx!

I have the same problem and tried it like you described. The problem is that after installing macfuse 4.4.1 the Seadrive Client overwrites it with 4.2.1 every time I start it. What to do?

to solve that i had to copy the macfuse.fs 4.4.1 into the seadrive application. to do so right-click on seadrive and click “show package contents”. now navigate to the “resources” folder and replace macfuse.fs

thank you. I deleted the macfuse.fs in the “resources” folder of Seadrive, but how do I replace it? I only got the macfuse-4.4.1.dmg file which does not seem to work and if I install it, I can’t find anywhere else?

install the .pkg from the dmg. then look in the macos system settings for the macfuse tab. there i had to manually update 4.2.1 to 4.4.1 again. after thats done go to the folder “/Library/Filesystems/macfuse.fs”.
There you should find the updated file. now copy this file into the seadrive application

It worked. You saved my life! Thank you

But after a restart I am back to square one :frowning:

Now it works. The macfuse.fs was not in “resources”.
Thank you very much

i just realised that i didn’t perform a reboot after “fixing” it. After reading your post i went back to the seadrive resources folder and set the macfuse.fs file to “read only” by opening the file information and scrolling down to the bottom. all permissions have to be read only.

now i did a reboot and it still works

ok :slight_smile: then the “read only” stuff is not necessary.

Didn’t work for me unfortunately. When I replace macfuse.fs 4.2.1 with 4.4.1 in the “resources” folder of Seadrive, Finder reports the Seadrive App to be “damaged”. What to do?

didn’t work for me as well.

Managed to fix with the steps below:

  1. Install Seafile it will ask for the permission on the kernel, privacy and security > allow > restart
  2. Install macFUSE 4.4.1, restart the computer
  3. Go to the folder “/Library/Filesystems” and copy macfuse.fs to another place (just to do a backup)
  4. Run Seafile it will ask for the permission on the kernel and will downgrade macFUSE, privacy and security > allow > restart
  5. After restart go to Find > Application > right button on seafile > Show Package Contents > Contents > Resources > paste “macfuse.fs” the one that you have saved before into there (will replace what is there )
  6. Run seadrive.exec on that folder (Not sure if that step is necessary but saw it in an old issue for seafile, so I ran it)
  7. Open Seafile it will ask for the permission on the kernel, privacy and security > allow > restart
  8. Run Seafile it will work

Fantastic, thanks @christian.magalhaes – worked for me as well (after several reboots)

A new version 2.0.24 has been uploaded to be compatible with macOS 13. You can have a try.

1 Like

Could you update the changelog?

1 Like

The change log has been updated.

1 Like

@onionstalgia Could mark this topic as solved?