SeaDrive: Error 0x8007045D: The request could not be performed because of an I/O device error


I have a seafile running on ubuntu 20.04 with a HDD of 4TB attached via usb.

I have installed the SeaDrive v1 (also tried with v3) on a windows 11 and windows 10 machines.

SeaDrive and web version work ok, but the problem appears on large files.
We migrated form NextCloud to SeaFile because we work with large video files, for example 6-7 Gb / .mp4

If we copy the files in Windows Explorer to SeaDrive, all works great.
If we download the files via web interface, all works great.
The problem is when we try to copy a 1 GB + file from Windows Explorer from SeaDrive to local HDD, the error “Error 0x8007045D: The request could not be performed because of an I/O device error.” pops up.

For smaller files, all works great, but for our need, 5+ GB per file, we get this error.

We tried SeaDrive v1 and v3, same error.

Anyone knows if it’s a config issue? We modified the seafile.config with greater values, still no luck.

Here is my /srv/conf/seafile.conf

port = 8082

use_block_cache = true
block_cache_size_limit = 10000
block_cache_file_types = mp4;mov
skip_block_hash = true

type = mysql
host =
port = 3306
user = seafile
password = ***
db_name = seafile_server
connection_charset = utf8

keep_days = 7

expire_days = 15

Thank you in advance!

What version of Seafile server are you running?

Have you tried adjusting the cache setting in the SeaDrive app?

It looks a lot like this issue that apparently needed an upgrade from Development.

Server Version: 9.0.10
Cache size 50GB

So it is a great file sharing solution but not for large files, right?

I’m not sure there is a large file issue per se. There are a number of complaints on this forum about SeaDrive on both Mac and Windows and I suspect Development is aware of the issues and working a couple new releases.

Maybe @Jonathan weigh in on this issue and let us know if SeaDrive is being looked at or if there are any issues relating to this on Server v.9?

You should use 3.x version. 1.x version is no longer maintained. You can check seadrive.log for error messages. You can open log folder from an menu item in the system tray icon.