SeaDrive Fedora Repo

I just tried to install seadrive on a fresh install of Fedora 31. The repo address returns a 404. Followed the instructions in the documentation. Either the repo doesn’t exist or the url in the Repo file is incorrect.

Unfortunately, there is no SeaDrive repo for Fedora 31. However, you can point to Fedora 30 to get the client installed. Works just fine for my laptop.

Modify your /etc/yum.repos.d/seadrive.repo to the following:

[seadrive]
name=seadrive
#baseurl=https://rpm.seadrive.org/fedora$releasever
baseurl=https://rpm.seadrive.org/fedora30
gpgcheck=0
repo_gpgcheck=1
gpgkey=https://bintray.com/user/downloadSubjectPublicKey?username=bintray
enabled=1

I’ll give that a shot, Thanks!

I’ve just tried it on Fedora32 (Openbox - not Gnome) and I get this:

Errors during downloading metadata for repository ‘seadrive’:

  • Status code: 521 for https://rpm.seadrive.org/fedora32/repodata/repomd.xml (IP: 104.18.59.193)
    Error: Failed to download metadata for repo ‘seadrive’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Ignoring repositories: seadrive

That’s with /etc/dnf/seadrive.conf that I copied from above.

We’re working on an official Fedora repository. It’ll be available very soon.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)