SeaDrive Issues with Large Folders

Hi All,

Just a quick one to get off my chest - when using the SeaDrive 3.0.#, it is saying that there is folders that are too big to sync, but my question is why not use caching so that you can still see the files and folders so that you can only download them when needed?

I am struggling to do a migration because of the fact that the folders are missing from the directory because they are ‘Too large to sync’.

Is there any way of getting round this without having duplicate files? (As uploading through the Web creates duplicates if the files are already there).

Thank you!

Just another thing to add to this, I don’t want to use the WebDAV purely because of speed - another thing is that the people that are using the system are able to see through the folders, but they are all on MacOS.

@daniel.pan @Jonathan

Since 8.0 version there is a default limit on the number of files that can be synced in a library. Please refer to: seafile.conf - Seafile Admin Manual

New in Seafile Pro 7.1.16 and Pro 8.0.3: You can set the maximum number of files contained in a library that can be synced by the Seafile client. The default is 100000. When you download a repo, Seafile client will request fs id list, and you can control the timeout period of this request through fs_id_list_request_timeout configuration, which defaults to 5 minutes. These two options are added to prevent long fs-id-list requests from overloading the server.

Since Pro 8.0.4 version, you can set both options to -1, to allow unlimited size and timeout.

max_sync_file_count = 100000
fs_id_list_request_timeout = 300
1 Like

Hi @Jonathan,

Thank you so much for getting back to me!

I have added these settings and then it is working fine now - I must’ve missed this during the setup so my apologies!