SeaDrive Mac 3.0.4 - Failed to start searpc server

I installed SeaDrive 3.0.4 on MacOS Ventura 13.4.1.
My Seafile server is 10.0.1.
The client starts, but gets stuck at “Starting …”.
These are the logs:


[07/06/23 20:48:32] Unix socket path /Users/marxxxxxxarotto/Library/Containers/com.seafile.seadrive.fprovider/Data/Documents/data/seadrive.sock is too long.Please set or modify UNIX_SOCKET option in ccnet.conf.
[07/06/23 20:48:32] seadrive.c(548): Failed to start searpc server.

[07/06/23 20:51:37] pipe client failed to connect to server: No such file or directory

1 Like

identical behaviour for me.

Seadrive 3.0.4 beta mac
M1Max MacBook Pro 16.
macOS 14 Sonoma Dev Beta 3

No answers from the forum. I wonder if opening a Issue on GH is more appropriate.

I have the same error on macOS 13.4.1(c).
I think this would be the best way. But where is the repository for the 3.0.4 beta version? I only find sea drive-fuse and seadrive-gui.

Well, maybe seadrive-fuse would be the right repo, but on none of them you can open an issue …

Hello,this issue will be solved in next version, which will be released in next month.

1 Like