Seadrive- You do not have enough permissions for this library

Hey Everyone,

Having a strange issue and thought I would reach out here, in case anyone else has had this issue.
On our seadrive all of a sudden everyone is getting a ‘you do not have enough permissions to access this library’ on two libraries all others are fine, and those two libraries also work correctly on the web interface. I also get this issue and I am the owner of the library.
I have tried rebooting sea file and logging out and back with and without removing local cache.

Has anyone has a similar issue
running sea file-pro server 7.0.10 and seadrive 1.0.11 (also tried 2.0.3)


I just get the same error with 2 clients, both on Windows. Only two library affected, all others fine.
I manage to fix things but did not clearly understand how, here is what I have done :

On client side :

  • close Seadrive
  • remove ~/seadrive/data directory
  • start Seadrive

On server side :

  • remove user from the group
  • add user to the group

Can you search the seadrive.log for the word “clone”? Does the permission denied issue happened during cloning a repo? If so, it’s a know bug and will be fixed in 2.0.5 version.

sorry logfile was cleared.

Same issues on many seadrive clients, both Windows and Mac. No data yet for Linux ones.
See my post here: SeaDrive 2.0.4 - Error when accessing shared library

On a Mac with SeaDrive 2.0.6 which experienced the problem I tried logging out without cleaning the cache. Loggin in, the error was there again.

I then logged out and instructed SeaDrive to remove the cache.
I checked the .seadrive cache directory - 34GB were still in use by this RO “shared to all” library, in a delete-<libraryID>.
Then I logged in again on SeaDrive. The re-caching lasted for a long time. The 34GB started being removed, until the cache directory was empty.
By browsing the library only the opened files were cached.
The original error hasn’t appeared again yet.

Also, when checking for updates, SeaDrive gave out a network error.
Downloaded version 2.0.10, upgraded. Check for updates -> still error.

Hi, I’ll upgrade my servers to 7.1.5 since I am currently running 6.3.4, and I’ll pray that will fix all this…
Ivan_Andrian : What version are you running ?

I’ll keep you inform of results.

This issue will be fixed with 2.0.12 version. It’s due to the SeaDrive client sometimes creates an empty update and tries to upload it. If the library is read-only, it causes permission errors.

Good to know, thanks Jonathan.
Looking forward to version 2.0.12 then.