Seaf-cli: SSL-Problem


I am trying to use the seaf-cli on ubuntu 16.04. I installed it following this instruction:

(BTW: How to find out which version is installed?)

That worked. Then I tried to list libraries from the server. The server is using a self signed certifiacte and the client on windows 10 works with it but seaf-cli returns the following error:

Traceback (most recent call last):
  File "/usr/bin/seaf-cli", line 832, in <module>
  File "/usr/bin/seaf-cli", line 828, in main
  File "/usr/bin/seaf-cli", line 355, in seaf_list_remote
    token = get_token(url, username, password, conf_dir)
  File "/usr/bin/seaf-cli", line 225, in get_token
    token_json = urlopen("%s/api2/auth-token/" % url, data=data)
  File "/usr/bin/seaf-cli", line 198, in urlopen
    resp = urllib2.urlopen(req)
  File "/usr/lib/python2.7/", line 154, in urlopen
    return, data, timeout)
  File "/usr/lib/python2.7/", line 429, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/", line 447, in _open
    '_open', req)
  File "/usr/lib/python2.7/", line 407, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/", line 1241, in https_open
  File "/usr/lib/python2.7/", line 1198, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>

I tried:

seaf-cli config -k disable_verify_certificate -v true

But that did not change the error message from seaf-cli.

Best regards,

Now, I tried the following:

  1. downloaded the .crt file of the server (self signed)
  2. copied it to /etc/pki/tls/certs/ca-bundle.crt
  3. sudo ln -s /etc/pki/tls/certs/ca-bundle.crt /etc/pki/tls/cert.pem

But I still get the same error.

I have to admit, that the common name in the certifiacte does not match the DNS name, but ignoring that work in the seafile-gui.

Best regards,

Hi Folks,

same issue here. My cert also is self-signed,. Windows client is doing fine. Debian client has same error than posted above by pfeffer. I wanted to post the cli version, but actually I could not find any paramater printing the version string?
Is there somewhere a description regarding the config keys?
Any idea how to get the seaf-cli running without any changes to the cert?


Have the same problem on Arch Linux