Seafile 7.1.3 CE creates absolute download links

Hi everybody,

I run a Seafile CE server in my intranet on CentOS 7. When I upgraded to 7.1.3, I noticed that the server uses absolute links when using the “Download” button on a file. This breaks the android client for me because the intranet name resolution does not work on my mobile phone and I access the server by its IP.

Also, this circumvents https which is not a great issue in an intranet but should also not happen.

Example: If I access the server with https://server-name/, the download link will be http://server-name:8082/.../file

Is this issue known?

Best regards,

Hi Johannes,

welcome to the Seafile Community Forum!

I am not sure I understand your problem. So let me ask you some questions:
1.) Are your talking Seafile’s webinterface or Android app?
2.) Are you running your Seafile without Apache/nginx?
3.) Are you sure your Service_URL and File_Server_Root is correctly configured? Please check in your / ccnet.conf and the system administration (see screenshot below).

Dear Ralf,

Thanks for your message and your kind welcome!

About 1.): I’m sorry, my description of the problem was a little brief - downloading files using the android apk failed and I found out that the links were the issue when I tried downloading using the mobile’s browser.

About 2.): I’m using Nginx with the recommended configuration from the server manual, i. e. / to host:8000, /seafhttp to host:8082 and so on.

About 3.): That’s it - the values in the system administration did not make much sense because they bypassed the Nginx routing (FILE_SERVER_ROOT was http://host:8082/file. Maybe this got mixed up during the upgrade from 7.0.5 which produced some weird error messages.

I set the two values to and, accordingly. Now it works again - thank you very much!

Best regards,