Seafile 9.0.4, NGINX and 404 errors

Have completed a new install. Version 9.0.4, MySQL and Nginx. OS is Debian 11. This is not a Docker install.
I am working to set up Nginx to use subdirectories, not server names so the URL will look as follows: The reason for this is I have several other small sites already set up as subs and would like to be consistent.
Any to do an upload or download (seafhhttp) results in a 404. The error and access logs provide no clues. Seafile runs as the user seafile and is in the group www-data, Nginx runs as the user www-data and the group www-data so I don’t think it is file access issues. Guidance would be greatly appreciated.

Below is the site config for seafile. Please note the root under the 3rd location is correct. Seafile lives on its own mount point /seafile.

Update: I see the scrolling blocks are messy. Sorry I’m not sure how that happened or what to do to fix it.

11/26 - Solved. All the references to the server URL must agree. I took another spins through the articles here in the forum and one more spins through all my config files. Life is good. This is solved.

** Start site config for seafile **
server {
listen 80;
listen [::]:80;
server_name seafile;
autoindex off;
client_max_body_size 100M;
access_log /var/log/nginx/seafile.access.log;
error_log /var/log/nginx/seafile.error.log;

 location ~/seafile {
        proxy_set_header   Host $host;
        proxy_set_header   X-Real-IP $remote_addr;
        proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header   X-Forwarded-Host $server_name;
        proxy_read_timeout  1200s;

 location /seafhttp {
        rewrite ^/seafhttp(.*)$ $1 break;
        proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_connect_timeout  36000s;
        proxy_read_timeout  36000s;
        proxy_send_timeout  36000s;
        send_timeout  36000s;

location /media {
        root /seafile/seafile-server-latest/seahub;


** Start nginx.conf

user www-data;
worker_processes auto;
pid /run/;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;

http {

    # Basic Settings

    sendfile on;
    tcp_nopush on;
    types_hash_max_size 2048;
    # server_tokens off;

    server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    # SSL Settings

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    # Logging Settings

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    # Gzip Settings

    gzip on;

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

    # Virtual Host Configs

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;


Closing as resolved.