Seafile CE to Pro migration issue: No module named 'seaserv'


I’ve upgraded Seafile from Community Edition 9.0.10 to Pro 9.0.10 according to the manual and got an error when starting

root@seafile:/opt/seafile# su - seafile -s /opt/seafile/seafile-server-latest/ start

LC_ALL is not set in ENV, set to en_US.UTF-8
/opt/seafile/seafile-server-latest/ line 228: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or directory
Starting seahub at port 8000 ...

Error happened during creating seafile admin.

Seahub is started


When starting with bash -x we see this happened just before the message:

+ echo 'Starting seahub at port 8000 ...'
Starting seahub at port 8000 ...
+ check_init_admin
+ check_init_admin_script=/opt/seafile/seafile-pro-server-9.0.10/
+ python3 /opt/seafile/seafile-pro-server-9.0.10/

Error happened during creating seafile admin.

Tried to run /opt/seafile/seafile-pro-server-9.0.10/ alone:

root@seafile:/opt/seafile# python3 /opt/seafile/seafile-pro-server-9.0.10/
Traceback (most recent call last):
  File "/opt/seafile/seafile-pro-server-9.0.10/", line 19, in <module>
    from seaserv import ccnet_api
ModuleNotFoundError: No module named 'seaserv'

I have searched for the error “No module named seaserv” but haven’t found how to solve this particular case.
The seaserv module is present:

root@seafile:/opt/seafile# find . -name seaserv

Thank you for your help.


I am getting the same error. Did you find a solution?

the solution:
link seafile-pro-server-10.0.4/seafile/lib64/python2.7 to seafile-pro-server-10.0.4/seafile/lib64/python3

Do you mean create a symbolic link from the python2.4 directory to python3? I’ve tried that and it still didn’t work. I know enough about Python to know it’s importing a library/API for use in the script.

I’m attempting to upgrade an existing Pro system from 9.0.16 to 10.0.9. I wonder if there is another component that needs upgrading?