Seafile Client on Windows high CPU usage

Hi all,

I am running the latest Seafile Client (7.0.2) on Windows 10.
Lately, I noticed that is using constant CPU between 15%-20% even while not synching.
No files changes, so the client should be idle.
Closing the app using the tray icon and starting it again solves the problem for some time until the CPU usage is back.
I already uninstalled and installed.

Thanks for your ideas.

Please check the log files if is there is any activity and what kind. You access the logs folder via the context menu of the systray icon.

Also: Disable you AV programm and try again. Check if you have two AV programms running (such as Defender and a third party AV programm).

We oberserve the same horrible explorer.exe CPU problem here. Even with AV completely uninstalled, the Seafile client is now blocking the exploer.exe almost completely while running.
If we terminate the explorer.exe and restart it then after about a minute the same CPU cycles begin to eat up CPU and explorer memory.

When terminating the seafile client the problems stops after only a few seconds, leaving the explorer.exe dormant and quiet as usual.

While writing this post the explorer.exe takes up around 40% CPU according to the taskmanager and renders any explorer window completely unusable. Most of the windows are now *not responding" anymore (Visible in the taskmanager)

This problem is consistent since 1 year now and through all updates and versions. It NEEDS to be solved because if it’s not then there’s no way we continue to recommend the system to our customers.

Please help

Hi Nick,

sorry that you encouter these problems.

We can try to help you fix the problem. But you need to provide more details:

  • Which Seafile client do you use?
  • Which version?
  • Your Windows version?
  • Is it a general problem on all devices or only on one?
  • What AV programm is installed/active?
  • Does the problem persist if you log out of SeaDrive while continuing to running it?

The conflict you observe is not a general one! I talk to many customers and if it was more prevalent, I would have noticed. In the same vein, there would be many more comments here in the forum. In other words, it must have something to do you with your machine/configuration.


What are the HW specs?

Intel i9-9900K, 2x2 TB M.2 SSD, 32GB, GF 1080ti, Win10 Pro
Read/Write Speed of the new SSDs is phenomenal, the CPU cores
are always idling about even when starting performance hungry games.

It takes about 3 hours, then the explorers task went back to normal.
No errors or warnings in the ccnet.log or seafile.log. Nothing out of the ordinary.

But the seafile client blocks the windows explorer completely. Whatever it does
during that time - this is not right.

And waiting for 3 hours every day when starting your system is not an option.

Did you solve the issue? Tell us about it

On the contrary - additionally if I delete let’s say 300 MB of files from my seafile folder the same explorer blocking happens again - and agin when I move another 300 MB into the seafile folder.

Just for your infomation:

I had the same issue with high explorer cpu usage.

It only appears if i tried to sync a windows built in “user folder” like /Current User/Documents. After Upgrading to 7.0.9 the problem went away.