Seafile community edition 11.0.4 and SeaDoc 0.5 are now ready!

We are glad to announce that Seafile community edition 11.0.4 is ready. It is a stable release.

In Seafile version 11.0.4, we have continued to make some improvements to the software’s UI and functionality:

  • Improvement of Seafile’s login dialog UI
  • When creating a new office file, the office new file template is selected based on the user’s current language
  • Other UI improvements and fixes

The docker image has also be improved. Now it is built upon the official Ubuntu 22.04 image. We have also include a script, so that you can build your own binary package for different platforms (X86 or arm-64) easily: seafile-docker/build at master · haiwen/seafile-docker · GitHub

The main changes in SeaDoc 0.5 include:

  • Added find and replace feature
  • Improved callout element, now callout element can have an icon
  • Made it easy to link other sdoc documents
  • Notification display improved
  • Other UI improvements and fixes

Let’s look at the details below:

Seafile 11.0.4

Improvement of Seafile’s login dialog UI

Compared to the previous dialog, the improved dialog is more concise.

SeaDoc 0.5

Added find and replace function

You can find or replace words in the entire document.

Improved the callout element

The icon function of the callout element helps to better highlight specific text.

Made it more easy to link other sdoc documents

The “[[” shortcut key can link to the sdoc document you want more easily. After typing “[[”, you will be prompted with recent visited files, you can search and find files. You can also create a new linked sdoc file.

Notification display improvement

A red dot will be added to the favicon when there is a new notification.

Other changes and fixes

  • Correcting the issue with the position of the horizontal drag line in the table
  • Adding the function of indentation with the Tab key
  • Modifying the prompt style for deleting comments
  • Improved the interaction settings for images

Regarding Seafile CE 11.0.4, are there any updates or additions required in the Manual for this upgrade?

No special steps involved.

I’ve just upgraded to 11.0.4.

The bug with the missing captcha described here is still there.

You should update the pillow package according to

I’ve done that when upgrading to 11.0.3 and just rechecked the currently installed PIP3 packages. Everything fits here for the versions required.

Maybe it is related to some other package compatibility issue. We will give it a check.

The captcha issue should have been fixed in version 11.0.5.

Will there be a non-docker version also for Seadoc? For me, it feels a bit odd to install a plain stack next to a dockerized VM, and I won’t install docker on a stack with a plain Seafile installation… Conclusion is that I don’t install it.

No luck here. I have just upgraded to .5 and the captcha is still missing.
Here is how it looks:

Maybe you need to reinstall the dependancies?

sudo pip3 install future==0.18.* mysqlclient==2.1.* pillow==10.0.* sqlalchemy==2.0.18 captcha==0.5.* django_simple_captcha==0.6.* djangosaml2==1.5.* pysaml2==7.2.* pycryptodome==3.16.* cffi==1.15.1 python-ldap==3.4.3

Especially, pillow, captcha and django_simple_captcha

I’m afraid SeaDoc will only be distributed in Docker to reduce the maintenance work for us.

Just tried your pip3 install. Here is what got upgraded:

Installing collected packages: django-simple-captcha, captcha
Attempting uninstall: django-simple-captcha
Found existing installation: django-simple-captcha 0.5.17
Uninstalling django-simple-captcha-0.5.17:
Successfully uninstalled django-simple-captcha-0.5.17
Attempting uninstall: captcha
Found existing installation: captcha 0.4
Uninstalling captcha-0.4:
Successfully uninstalled captcha-0.4
Successfully installed captcha-0.5.0 django-simple-captcha-0.6.0

The rest of the dependencies was “already satisfied”. Still no captcha here.

Can you check if there are error logs at the server side?

Hust checked seahub.log. It actually contains errors when the captcha becomes active:

[ERROR] django.request:241 log_response Internal Server Error: /captcha/image/968fa18041594c9727f18f843c8e076b22c08d89/
Traceback (most recent call last):
File “/opt/seafile/seafile-server-11.0.5/seahub/thirdpart/django/core/handlers/”, line 55, in inner
response = get_response(request)
File “/opt/seafile/seafile-server-11.0.5/seahub/thirdpart/django/core/handlers/”, line 197, in _get_response
response = wrapped_callback(request, *callback_args, **callback_kwargs)
File “/usr/local/lib/python3.9/dist-packages/captcha/”, line 88, in captcha_image
File “/usr/local/lib/python3.9/dist-packages/captcha/”, line 33, in getsize
def makeimg(size):
AttributeError: ‘FreeTypeFont’ object has no attribute ‘getsize’

i’ve just installed 11.0.4 (to a non-root directory), set up a user account and can’t connect at all with seafile GUI 9.0.4. i just get a non-informative error that login was not successful. same account works with the browser.

in seahub.log i noticed this:

2024-02-04 22:22:30,734 [WARNING] django.request:241 log_response Not Found: /seafile/https://<my.domain>:<port>/seafile/api2/auth-token/

looks like the non-root directory was added as a prefix to the URL? i’ve had problems with the combination of 2FA and non-root installations before, but this is new. disabling 2FA revealed that it is not related – the problem remains unresolved and i get the same warning in the logs.

i’ve also noticed that both seahub.log and onlyoffice.log are present in /tmp for every user to read. /tmp/seahub.log has less information than seahub.log in seafile’s root dir. however, it puzzles me.

the logs also warned about a missing directory seahub/frontend/build. creating the directory made the warnings disappear.

edit: sorry for the noise about not being able to use the GUI client. copy&paste introduced a really stupid “typo” in the server address. fixed & works. however, the 2FA issue still exists two years later: completely new installation with 2FA enabled, clicking on the server address in the GUI client opens the wrong page (non-root subdirectory added twice).