Seafile community edition 9.0.10 is ready!

This is a maintenance release with following fixes and improvements:

  • Admin list all users API now return last_login and last_access_time
  • [fix] Fix a bug in displaying markdown file in sharing link
  • [fix] Fix notification mails are sent to inactive users
  • [fix] Fix viewing a file in an old snapshot leads to server hickup
  • [fix] Fix an HTTP/500 “Internal server error” when the user sets password containing non-latin characters for sharing links
  • [fix] Fix "document convertion failed” error visiting a shared document with preview only
  • [fix] Fix memory leak when block cache is enabled
  • Enable ‘zoom in/out by pinch’ for mobile in pdf file view page
  • [fix] Prevent system admin creating libraries with invalid name in admin panel
  • Improve performance in golang file server

Interestingly, the link from the website is still at 9.0.9, but by making a small change in the link (changing the 9 for a 10) everything worked.
Thanks for another smooth upgrade!

The latest version is also missing on the german page: Downloads | Seafile

And it looks as if there is some issue with the avatars. I am not sure if this is related to my reverse proxy, but before the upgrade it worked fine. See my separate post.

Hi all

I’ve just spun up a manual install of Seafile 9.0.10 on ubuntu 22.04.2LTS, using sqlite and I’m getting this error with nothing in the logs to show helpful info. I noticed a similar reply for a recent release thread, with no response.

user@myserver:/opt/seafile/seafile-server-9.0.10$ ./ start

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./ start" again

I’ve been through the fixes

pip3 install --force-reinstall --upgrade --target /opt/seafile/seafile-server- 
9.0.10/seahub/thirdpart cffi==1.14.6

and added

libffi-dev, ffmpeg, libopenjp2-tools, libtiff*

I see other posts reference to the mylsql client for pip, but I’m running sqlite - is it still a hard dependency?

Any other thoughts?

1 Like

A quick update for those stumbling through this issue and following the huge tangle of threads. I’ve literally re-installed everything as part of the pip3 steps ONLY (including the tweaked step for ubuntu 22.04 and cffi) - and today ./ start just works. No other system updates or external software updates / reinstalls performed.

I still had no content displayed when accessing the site either via the host machine’s local IP or its URL. I do have Caddy reverse proxying and issueing a valid (staging) certificate, but the URL presents a 502 in Firefox and Chrome. I disabled my host firewall, reboot and started seafile and seahub, again no errors - successful starts. Still 502 in the browsers.

I then proceeded to modify /opt/seafile/conf/
and change SERVICE_URL from my desired URL (entered during the initial setup script) to the local IP of the host and adding port 8000 (ie SERVICE_URL = '')
Then modify /opt/seafile/conf/ and change the bind to “” (ie bind = ""). Now the login screen presents!!

Firewall enabled, reboot, started seafile and seahub, again no errors - successful starts. Still have a login screen (and can successfully log in!)! A small win!!