Seafile community edition 9.0.4 is ready!

This is a maintenance release with following fixes and improvements:

  • Support admin enforcing a strong password in WebDAV secret
  • Improve UI of file moving/copying dialog to show folders with long names
  • Expand to the current folder when open file moving/copying dialog
  • Show current number of shared users and groups when deleting a library
  • Enable deleting fs objects in GC
  • Users can save files or folders in shared folder link to their own libraries
  • [fix] Fix WebDAV error while filename contains special chars
  • [fix] Fix language in calendar UI component used when picking date in sharing dialog
  • [fix] Fix markdown file print
  • [fix] Fix printing support of Markdown file
  • [fix] Fix zip-downloading in sharing links when golang file server is used
  • [fix] Fix a bug in golang file server log rotate support
  • [fix] Fix a bug in folder download-link and try to download files/folders as zip using golang file server

Easy upgrade! thank you, working great.

hy @daniel.pan

there is still a bug when downloading a whole folder like in 9.0.2:

If you just download 1 folder at once, the save as dialog does not add the .ZIP file extension per default to the file name.

Please take a look at this for the next release, thanks!

Can you post a screenshot? I can’t reproduce the problem.

This is what the Save As dialog shows when hitting the marked button:

I’m seeing the same behavior on the Mac (Catalina 10.15.7) with Firefox 97.0.1 on Seafile CE 9.0.4 under Ubuntu 20.04.

Could you please change cffi version to 15?
Version mismatch: this is the 'cffi' package version 1.14.0
I have it running on Arch an the python-cffi package is already on 1.15.0.


I’m sorry changing python-cffi to 1.15.0 will cause some problems in Ubuntu system as we have tested before.

Ah ok.

I use also certbot and certbot needs cffi 15. It’s possible to downgrade cffi to 14 and restart seahub and upgrade cffi back to 15 so that certbot can run automatically but that’s annoying :smiley:
But yeah, I hope you can get it fixed one day.

Do you use golang file server?

You can use instead. Dependencies are close to zero.

1 Like

Yes, golang file server.
OS: Ubuntu, native installation - no docker.

Yes, the issue with folder download is there only with golang web server.
I tried to fix with this PR: which was ignored, and then the maintainers made a identical PR:

Unfortunately this doesn’t fix, so the bug is still here.

you should use virtual environments if you need different versions of pip packages on the same system.
Or install the pip packages with different user, but the first option is more recommendable

1 Like

what’s the correlation with the golang web server here?

my answer was actually directed to @danSman

I have it running on Arch an the python-cffi package is already on 1.15.0.

Hey Folks,

since I upgraded from 9.0.2 to 9.0.4 on my raspi, webdav is not working anymore.

The wsgi process seems to be running fine and the log doesn’t show any error,so it’s hard to figure out what’s wrong.

$ ps -aux | grep wsgi
seafile 108 0.0 0.7 67712 56492 ? S 14:26 0:09 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/ --preload
seafile 109 0.0 1.0 104520 80268 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/ --preload
seafile 110 0.0 1.0 107760 83040 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/ --preload
seafile 111 0.0 1.0 104520 80264 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/ --preload
seafile 112 0.0 1.0 108452 83892 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/ --preload
seafile 113 0.0 1.0 107548 82940 ? S 14:26 0:02 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/ --preload
root 2047 0.0 0.0 2908 620 pts/2 S+ 19:27 0:00 grep wsgi

But a curl -v from my nginx-container, which is running in the same pod, doesn’t get any connection (tried curl directly from inside the pod to avoid possible nginx misconfiguration ).

# curl -v
Expire in 0 ms for 6 (transfer 0x559098fc30)
Expire in 200 ms for 4 (transfer 0x559098fc30)
connect to port 8080 failed: Connection refused
Failed to connect to port 8080: Connection refused
Closing connection 0
curl: (7) Failed to connect to port 8080: Connection refused

here’s my seafdav.conf

enabled = true
port = 8080
fastcgi = false
share_name = /seafdav
workers = 5
timeout = 1200

OK I missed looking into controller.log
There i found this error

importError: cannot import name ‘soft_unicode’ from ‘markupsafe’ (/home/seafile/seafile-server-9.0.4/seahub/thirdpart/markupsafe/

This is a breaking change introduced in new markupsafe release:

The following did the job for me:

python3 -m pip install --force-reinstall --upgrade --target <SOMEWHERE>/seafile-server-9.0.4/seahub/thirdpart markupsafe==2.0.1
1 Like