Seafile community edition 9.0.4 is ready!

Can you post a screenshot? I can’t reproduce the problem.

This is what the Save As dialog shows when hitting the marked button:

I’m seeing the same behavior on the Mac (Catalina 10.15.7) with Firefox 97.0.1 on Seafile CE 9.0.4 under Ubuntu 20.04.

Could you please change cffi version to 15?
Version mismatch: this is the 'cffi' package version 1.14.0
I have it running on Arch an the python-cffi package is already on 1.15.0.

Thanks!

I’m sorry changing python-cffi to 1.15.0 will cause some problems in Ubuntu system as we have tested before.

Ah ok.

I use also certbot and certbot needs cffi 15. It’s possible to downgrade cffi to 14 and restart seahub and upgrade cffi back to 15 so that certbot can run automatically but that’s annoying :smiley:
But yeah, I hope you can get it fixed one day.

Do you use golang file server?

You can use acme.sh instead. Dependencies are close to zero.

1 Like

Yes, golang file server.
OS: Ubuntu, native installation - no docker.

Yes, the issue with folder download is there only with golang web server.
I tried to fix with this PR: https://github.com/haiwen/seafile-server/pull/539 which was ignored, and then the maintainers made a identical PR: https://github.com/haiwen/seafile-server/pull/545

Unfortunately this doesn’t fix, so the bug is still here.

you should use virtual environments if you need different versions of pip packages on the same system.
Or install the pip packages with different user, but the first option is more recommendable

1 Like

what’s the correlation with the golang web server here?

sorry,
my answer was actually directed to @danSman

I have it running on Arch an the python-cffi package is already on 1.15.0.

Hey Folks,

since I upgraded from 9.0.2 to 9.0.4 on my raspi, webdav is not working anymore.

The wsgi process seems to be running fine and the log doesn’t show any error,so it’s hard to figure out what’s wrong.

$ ps -aux | grep wsgi
seafile 108 0.0 0.7 67712 56492 ? S 14:26 0:09 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/gunicorn.conf.py --preload
seafile 109 0.0 1.0 104520 80268 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/gunicorn.conf.py --preload
seafile 110 0.0 1.0 107760 83040 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/gunicorn.conf.py --preload
seafile 111 0.0 1.0 104520 80264 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/gunicorn.conf.py --preload
seafile 112 0.0 1.0 108452 83892 ? S 14:26 0:01 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/gunicorn.conf.py --preload
seafile 113 0.0 1.0 107548 82940 ? S 14:26 0:02 python3 /home/seafile/seafile-server-9.0.4/seahub/thirdpart/bin/gunicorn seahub.wsgi:application -c /home/seafile/conf/gunicorn.conf.py --preload
root 2047 0.0 0.0 2908 620 pts/2 S+ 19:27 0:00 grep wsgi

But a curl -v 127.0.0.1:8080 from my nginx-container, which is running in the same pod, doesn’t get any connection (tried curl directly from inside the pod to avoid possible nginx misconfiguration ).

# curl -v http://127.0.0.1:8080
Expire in 0 ms for 6 (transfer 0x559098fc30)
Trying 127.0.0.1…
TCP_NODELAY set
Expire in 200 ms for 4 (transfer 0x559098fc30)
connect to 127.0.0.1 port 8080 failed: Connection refused
Failed to connect to 127.0.0.1 port 8080: Connection refused
Closing connection 0
curl: (7) Failed to connect to 127.0.0.1 port 8080: Connection refused

here’s my seafdav.conf

[WEBDAV]
enabled = true
port = 8080
fastcgi = false
share_name = /seafdav
workers = 5
timeout = 1200

OK I missed looking into controller.log
There i found this error

importError: cannot import name ‘soft_unicode’ from ‘markupsafe’ (/home/seafile/seafile-server-9.0.4/seahub/thirdpart/markupsafe/init.py)

This is a breaking change introduced in new markupsafe release: https://github.com/pallets/markupsafe/issues/284

The following did the job for me:

python3 -m pip install --force-reinstall --upgrade --target <SOMEWHERE>/seafile-server-9.0.4/seahub/thirdpart markupsafe==2.0.1
1 Like

Great, this works for me as well.
Thanks!

@daniel.pan @Jonathan please verify and patch the bundled libs.

We will give it a check.