Seafile Docker: Upgrade from 10.0.4 to 10.0.5 makes browsing files super slow

I have Seafile running as a Docker container.
In the Docker configuration, you need to specify the Seafile version. I mistakenly specified 10.0.5 even though the image was 10.0.4. I didn’t realize it at the time. It is the ENV SEAFILE_VERSION.

When 10.0.5 was released, I couldn’t switch to the newer version. So, first, I changed 10.0.4 from 10.0.5 version under /opt/container/seafile/seafile-data/seafile/seafiledata/current_version. Then, I was able to update the Seafile Docker to the latest image version. Unfortunately, Seafile is now running very slowly when browsing data in the browser.
I reverted back to the old 10.0.4 image, and everything works fast again. But i have still the problem that it is displayed as 10.0.5 in the current version internally (ENV SEAFILE_VERSION 10.0.5 and current_version also 10.0.5 but the image is 10.0.4).

Any help how to get this right?
And why is Seafile so slow in version 10.0.5?

any help / advice?

Are you using memcached perhaps? I feel like when this happened I added Memcached into equation and normalcy resumed.

Yes i have all dockerized:

  • seafile.mysql
  • seafile.memcached
  • and seafile itself as docker

What do you mean “added Memcached into equation and normaly resumed” ?

Now i have tried to update from 10.0.4 to 10.0.6. Same issue. Everything is super slow to load. Waiting 10 times more till the page of a library is shown.
Any help :frowning: ?

Ok after reboot of my server, it works fast again. :heart_eyes:

Ok after a second reboot, i got “502 Bad Gateway”. I dont get it how an update can make so much issues :frowning:

The error in the seafile container is:
waiting for mysql server to be ready: %s (2003, “Can’t connect to MySQL server on ‘db’ ([Errno 113] No route to host)”)

I haven’t changed anything. Only upgraded the seafile container to the new version. Any help?

After some investigation, I modified the environment setting of the Seafile container from DB_HOST = db to DB_HOST =

The change didn’t take effect immediately. I had to restart all Seafile services and reboot the server because simply restarting the Seafile container didn’t update. The log still output looking for the database under the name “db”.

I’m just confused why i have to change this, when it works for 2 years without any issue.