Seafile high java CPU load

Hello,

i am using seafile pro 7.0.7 on a debian buster root server and started to notice something that seems suspicious to me. When i start htop there are several java entries that repeatedly seem to consume lots of cpu for a few seconds. After that the cpu load seems perfectly normal until it comes up back again like you see in the picture.

Even though there are no obvious problems when we are using seafile so far i still would like to know
if this is intented or something i should look into more closely.

Thanks in advance for your help

Dennis

Hi,

actual I have the same problem. Maybe since I upgrade from 6.x to 7.x.
I hope anybody can help us. :slight_smile:

Thanks
Michael

I disabled the file index by setting

[INDEX FILES]
enabled = false

in ./conf/seafevents.conf. The cpu and memory load is normal again.

Elasticsearch seems to be the problem. I found this line in the elasticssearch.log:

[2019-09-03T15:37:53,897][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/opt/srv/seafile/pro-data/search/data/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
OK… it on warn level, but elasticsearch will be restarted and restarted again and again. I guess this is the reason for the high system load.

so I deleted the entire ‘pro-data/search’ folder and activated the file index and started seafile again. I hoped the file index would be created and all will be fine but this didn’t fixed my problem. CPU load is on max.

I deactivated file indexing again and I’m waiting for a solution.

I can confirm what you described. Immediately after setting INDEX FILES to false, the high CPU load disappears completly. You might also be able to install elasticsearch seperately and set the
es_host and and es_ports setting in seafevents.conf accordingly.

If any of the devs is seeing this, it would be good to know if this can be considered a bug and if they are fixing it.

Thanks

Hi guys, I have the same issue after I make the upgrade to seafile 7.0.11 I notice the same behavior as you describe.
I disable the index, delete the ‘pro-data’ folder and enable the index and the issue still persist.

Is someone that find how to fix this?

Hello All,

I have to let seafile container off…

Seafile and elasticsearch are the root cause of a very high load (AVG : 500…)
I will post a screen shot, i have never seen that before !

I have this issue too.
First appeared when upgrading from Pro 6.x to Pro 7.0.9. Tonight I moved up to Pro 7.0.11, problem continues.

Hi,

for me this was the solution to stop the usage of the CPU excessive 'It seems there are orphaned Java processes somewhere. Stopped seafile, killed the process and it’s back to normal for me’

I found on this topic: Seafile pro edition 7.0.8 is ready!

I am using seafile from 5 years and I never seen that before…

Seafile container is killing my server…

On the proxmox side :


I tried to set ulimit in the container configuration without success.
if I let the container running load can increase to 800 !
I also tried to downgrade to 7.0.2 but problem is persisting