Seafile mit OnlyOffice Integration - Seite bleibt weiß


#21


Kann es an dem selbst signiertem Zertifikat liegen? Zumindest gibt er mir in den Logs eine Info aus, das hier scheinbar etwas schief läuft.

Edit: Ich könnte Test weise versuchen auf only http umzustellen um zu sehen ob es grundsätzlich funktioniert und um das Zertifikat als Problem ausschließen zu können.


#22

Also ich bin ein schritt weiter. Das Dokument lässt sich nun im Browser öffnen. Ich habe in der /etc/onlyoffice/documentserver/default.json den Punkt “rejectUnauthorized”: auf false gestellt und den container neu geladen.

Einträge ändern und speichern geht jedoch noch nicht. Da muss ich noch einmal in die Logs schauen. Ich bekomme den Folgenden Fehler:

Edit:

Der erste Fehler scheint die fehlende Hilfedatei zu sein für die Deutsche Unterstützung. Der Ordner fehlt einfach. Dürfte jetzt nicht das Problem sein. Im Zweiten Teil sieht man aber das er scheinbar keine Berechtigung hat das Dokument zu schreiben. Ich weiß aber leider nicht, an welcher Stelle ich hier noch einmal nachschauen kann. Irgend eine Berechtigung setzen oder eine Config ändern.

Das Dokument wird ja von Seafile gespeichert. Ich vermute, dass der Documentserver keine Berechtigung hat das Dokument verändert zu speichern. Also fehlt doch sicher irgendwo eine Berechtigung. Aber wo? :smiley:


#23

Irgend jemand noch eine Idee? :grinning:


#24

Ich habe ganz viele Ideen, du musst dich nur ein paar Tage gedulden. Bin aktuell sehr mit Arbeit dicht. :wink:


#25

Sehr gern, das bekomme ich hin. Danke :slight_smile:


#26

Moin, ich habe immer noch wenig Zeit, hatte aber vor kurzem ein Problem mit meinem OODS.
Daraufhin habe ich den Container gelöscht, das neuste Image geladen und dann deployed.

Danach habe ich die Nginx Security Settings leicht gelockert und es lief wieder.

Probier mal das neuste Image jetzt zu ziehen und schau ob es geht.