Seafile not properly restarting after reboot, not even able to fix it manually

I set up seafile last week. Had problems on Ubuntu 20.04, but on Ubuntu 18.04 the script worked. Seafile is the only service running on that VPS and at least for the foreseeable future I’ll keep it that way.

After running the script, I made the following changes:

  1. Enabled https as described in the manual
  2. Added systemd services to start up on bootup as described in the manual

Today (before the server reboot), my client didn’t connect to the server properly. Additionally, on the web frontend (seahub, if I’m correct) it shows “Error” in red font under “My libraries”.

I tried rebooting the server and hoped the systemd services would automatically bring everything back up correctly. Didn’t work. Sometimes not even the web interface got back online (not sure whether that was before or after the reboot).

Manually evoking “systemctl start seahub/seafile” also didn’t solve the problem.

controller.log seems to be growing quickly. Looks like it wants to continuosly restart “seafdav”. I don’t even need WebDAV. Seems like it was installed by the script automatically.

Please help!

Solution: disabling seafdav worked.

Disable seafdav?

Tried starting Seafile/Seahub directly (not relying on SystemD)?

Post your controller.log?

It looks like disabling seafdav worked. Changed the flag in the config file to false and rebooted. Seems to work now. Let’s hope it stays that way. Thanks for the quick reply.

Hi Dunkelziffer,

glad I could help.

Under normal cirumstances, enabling WebDAV should not create any problems… It is a standard feature.

Could you mark this thread as solved?