Seafile Onlyoffice

HI,

stehe gerade etwas aufm Schlauch.
Wollte seafile und onlyoffice zusammenbringen.
Onlyoffice läuft auf docker und ist nur im lokalen Netzwerk erreichbar 192.168.2.124
Seafileserver läuft auf eignen Server (kein Docker) kann den onlyoffice auch erreichen.
Welcome auf http://192.168.2.124:88 geht
Config laut Manual gemacht http://192.168.2.124/web-apps
Also kein SSL, da der onlyoffice nur im lokalen Netz läuft ohne Kontakt ins Internet.
rejectunauthorized ist auch auf false
Aber immer wenn ich ein Dokument öffne kommt in der url der link
https://cloud.domain.de/lib/881ba0d7-33d0-4084-93ba-372a7c05e324/file/test.xlsx
aber sonst nix.

Das wirft der Firefox aus.
Laden von gemischten aktiven Inhalten “http://192.168.2.124/web-apps/apps/api/documents/api.js” wurde blockiert.
test.xlsx
Laden fehlgeschlagen für das mit der Quelle “http://192.168.2.124/web-apps/apps/api/documents/api.js”. test.xlsx:21:1
Uncaught ReferenceError: DocsAPI is not defined
https://cloud.domain.de/lib/881ba0d7-33d0-4084-93ba-372a7c05e324/file/test.xlsx:51

Was ist mein Denkfehler?

Gruß Mario

hallo

Habe es mit onlyoffice zusammen mit seafile versucht aber auch nicht ein Lösung gefunden.
Danach mit collabora (libreoffice) in combi mit seafile geschaft. Beide auf seperaten VPS.
Ich bin interessiert wenn Sie es finden.

mfg

Stephan

Bei mir funktioniert mit Onlyoffice-Dokumentserver auf Docker und Seafile auf eigenen Server. Beide im gleichen/lokalen Netz.

Firstly check the conf/seahub_setings.py:

# OnlyOffice Integration
# Enable OnlyOffice

ENABLE_ONLYOFFICE = True
VERIFY_ONLYOFFICE_CERTIFICATE = True
ONLYOFFICE_APIJS_URL = 'https://onlyoffice.domain.de/web-apps/apps/api/documents/api.js'
ONLYOFFICE_FILE_EXTENSION = ('doc', 'docx', 'ppt', 'pptx', 'xls', 'xlsx', 'odt', 'fodt', 'odp', 'fodp', 'ods', 'fods')
ONLYOFFICE_EDIT_FILE_EXTENSION = ('docx', 'pptx', 'xlsx')
ONLYOFFICE_JWT_SECRET = 'fakejwt_secretjasfjdshöfjasdhöfjhasdjöfhadjsghöadshgöjashgöhasögj'

Prüft bitte nach, ob es bei dir so ähnlich aussieht.

Schritt nach Schritt…

Hi, danke fürs Feedback

bei mir so

Enable Only Office

ENABLE_ONLYOFFICE = True
VERIFY_ONLYOFFICE_CERTIFICATE = False
ONLYOFFICE_APIJS_URL = ‘http://192.168.2.124/web-apps/apps/api/documents/api.js
ONLYOFFICE_FILE_EXTENSION = (‘doc’, ‘docx’, ‘ppt’, ‘pptx’, ‘xls’, ‘xlsx’, ‘odt’, ‘fodt’, ‘odp’, ‘fodp’, ‘ods’, ‘fods’)
ONLYOFFICE_EDIT_FILE_EXTENSION = (‘docx’, ‘pptx’, ‘xlsx’)

HI,
habe nun die Logik verstanden.
Also der Fehler liegt settings da muss die Url der kompletten server sein.

Frage nur warum kann ich nichts zu Bearbeiten freigeben?

Gruß mario

HI,

habe noch 2 Probleme.

  1. Ich kann nichts zu Bearbeiten freigeben, es ist immer so als würde ich es ohne Only office machen.
  2. 5m Speichern will nicht

{
“services”: {
“CoAuthoring”: {
“autoAssembly”: {
“enable”: true,
“interval”: “5m”
}
“sql”: {
“type”: “postgres”,
“dbHost”: “localhost”,
“dbPort”: “5432”,
“dbName”: “onlyoffice”,
“dbUser”: “onlyoffice”,
“dbPass”: “onlyoffice”
},
“token”: {
“enable”: {
“request”: {
“inbox”: false,
“outbox”: false
},
“browser”: false
},
“inbox”: {
“header”: “Authorization”
},
“outbox”: {
“header”: “Authorization”
}
},
“secret”: {
“inbox”: {
“string”: “secret”
},
“outbox”: {
“string”: “secret”
},
“session”: {
“string”: “secret”
}
}
}
},
“rabbitmq”: {
“url”: “amqp://guest:guest@localhost”
}
}

das lässt den onlyoffice nicht mehr starten

Gruß Mario

Keiner eine Ahnung?