Seafile pro ios file upload issue - edited file does not upload - file inconsistence


#1

edited file does not sync or upload
hi,
if i
create a new file in encrypted seafile library with seafile pro: upload ok
edit file first time: upload ok
edit file again: message appears - file changed, BUT changes does not upload!

or if i
edit a file with seafile pro in encrypted seafile library: upload ok
BUT: edit file again: message appears - file changed, BUT changes does not upload!

more - upload file does not work!

hardware: iphone 7 plus ios 10.3.2
iphone 6 ios 10.3.2
seafile server: hosted

i tried to remove app with all settings and files and clear cache, but nothing helped
clear chache resulted in an null file.
The file did only upload for one time :frowning:
if i change this file on desktop, it is NOT synced to iPhone :frowning:
syncing on desktop (linux and Mac works)

Info: its a markdown File


#2

We encounter similar problems connection and upload problems with the iOS app.

We have run tests with multiple iOS devices and we came to realize that - it sounds improbable though - it must have something to do with the device type.

  • iPhone 5/5s/5c: We had no connection and upload problems at all
  • iPhone 6: Some phones worked properly, others did not
  • iPhone 7: We didn’t get any device to work.

We have updated all phones to the latest iOS and Seafile app version. We tried to connect to two different servers with identical settings and login credentials.

Does anyone know of problems/conflicts between recent iPhone models and the Seafile app?

Looking forward to comments!
Ralf


#3

I have also similar problems with encrypted libraries and my iPhone 4s. I save regularly PDF-files created by Scanbot in an encrypted library. After saving in seafile it is often impossible to open the file. Sometime I need to export the same file two or three time untill I have a working copy, sometime it works with the first try.
How can we debug this?


#4

Hi ralph,

can i help you with debugging or something else?
Thanks Simsala for the great idea.

regards,
sisyphus


#5

Hi,
having similar problem on iphone SE (10.3.2) with edited files on the phone. They dont get synced to server(6.1.0) unless I restart the phone.

scenario;

  1. create a text file from the phone
  2. edit on the phone -> server updates ok
  3. edit from PC web interface -> refresh iphone client -> no updates on the phone
  4. edit on the phone again -> no updates on sever

BR,
/tompa

edit; actually no sync after restart, just another version of the file


#6

Sounds like an Problem with ios 10.3.x…? (ios 10.3.1 caused same problems)
Is there an github ticket or anything else for this bug?
Is there an recommended workaround until the bug is fixed?


#7

I’m experiencing upload problems on an iPhone SE, iOS 10.3.2: I can’t upload larger files (and by larger I mean something bigger than 50, 60 MB. which is not much at all by today’s standards), which are mostly videos from the photos app.

Sometimes it gets stuck uploading and the indicator bar doesn’t move, but most of the time the upload indicator simply disappears in like one second.


#8

Can you upload the files via web interface?


#9

I think this are two different problems. My edited files witch are not synced have only some bytes ore kilobytes.
Any ideas relating to this problem?
As a workaround, i have to export my markdown files to another app, edit it, export back to seafile, delete the old and rename the new file. This is very troublesome.
By the way: I have no problems uploading larger fies via web interface.


#10

Sorry, I can’t check it now. Yesterday I rebooted my server (I think it was the first reboot since I installed it two weeks ago) and it didn’t initialize Seafile automatically. I’m troubleshooting it now, as I’m not being able to start it. Maybe I’ll have to do a reinstall.


#11

Hi Ralf,

any new ideas about the problem with recent iPhone models ?
Can i help with debugging or anything else?


#12

Seems to be fixed for me in IOS v2.6.2


#13

Not fixed for me, iPhone 7 plus and 6, both with iOS 10.3.2


#14

Hi there,

same issue here too.

iPhone 7, iOS 10.3.2, Seafile App 2.6.2 -> No upload possible “auf Hochladen wird gewartet” (Waiting for Upload)
iPhone 5s iOS 10.3.1, Seafile App 2.6.2 -> Upload is working as aspected.

Upload over Web and other Clients on Windows and MacOS are working well.

Seafile CE 6.0.9 on Debian 8, nginx Proxy with Letsencrypt Cert.

If you need some logs or other information I will help you!

Philipp


#15

Hi all,

still problems with uploading fotos : no upload possible “auf Hochladen wird gewartet” (waiting for upload)

iphone8 IOS 11.2.2, Seafile App 2.7.2

Best regards

Jürgen


#16

Same here. About 2300 pictures and videos still waiting to upload, after several thousand uploaded successfully.


#17

I update server to latest 6.3.2 and no problem
Using iphone 7+ on IOS 11.3.1 + seafile 2.7.8


#18

Still problem with ios 11.4.1 and iphone 7+


#19

And still Problem with iOS 12.1, iPhone 7 Plus and iPhone 6.
Am I the only one that uses the seafile pro ios app and has this problem ?
The problem occurs afters changes the same file for several times