Seafile seafile-server-9.0.10 failed to start, throwing error

Downloaded a brand new Seafile 9.0.10 64bit distribution for Oracle Linux 7.9, with python 3 running with all the required packages, seafile server configuration has been completed successfully, however when I try to start the seafile.sh file, I am getting the below message. Any help would be appreciated.

[21/06 00:38:44] root@sjc51-c01-oem02 /u01/seafile/seafile-server-latest # ./seafile.sh start

Starting seafile server, please wait …
/u01/seafile/seafile-server-9.0.10/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.25' not found (required by /u01/seafile/seafile-server-9.0.10/seafile/lib/libcrypto.so.1.1) /u01/seafile/seafile-server-9.0.10/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.25’ not found (required by /u01/seafile/seafile-server-9.0.10/seafile/lib/libuuid.so.1)
Failed to start seafile server
[21/06 00:38:57] root@sjc51-c01-oem02 /u01/seafile/seafile-server-latest #

See the OS compatibility chart: Seafile Release Table

If I read it correctly, Seafile version 8 was the last to support Oracle Linux 7.9 (by way of supporting that being about the same as supporting RHEL 7.9, which is about the same as supporting Centos 7.9). With seafile version 9 and 10 it looks like Centos/RHEL/Oracle 8 is supported.

1 Like

Thank you for seafile table matrix, very helpful!
How do I get a link to download seafile version 8 or 7? as in the download page only version 9 and/or version 10 available.

Those old versions are technically not supported anymore, but I think you can just modify the version number in the download link. Change 9.0.10 to 8.0.8 and it should download (at least that worked back sometime in maybe the 7.0 era when I needed to do it once).

1 Like

Thank you for guiding me changing the download link version page, I was able to download 8.0.8 and tried to install it but now getting the following error: (when I try to do ./seahub.sh start-fastcgi 8000

[21/06 22:56:34] root@sjc51-c01-oem02 /u01/seafile/seafile-server-latest # ./seahub.sh start-fastcgi 8000

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub (fastcgi) at 127.0.0.1:8000 …
Traceback (most recent call last):
File “/u01/seafile/seafile-server-8.0.8/seahub/manage.py”, line 10, in
execute_from_command_line(sys.argv)
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/core/management/init.py”, line 381, in execute_from_command_line
utility.execute()
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/core/management/init.py”, line 357, in execute
django.setup()
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/init.py”, line 24, in setup
apps.populate(settings.INSTALLED_APPS)
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/apps/registry.py”, line 114, in populate
app_config.import_models()
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/apps/config.py”, line 211, in import_models
self.models_module = import_module(models_module_name)
File “/usr/lib64/python3.6/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 994, in _gcd_import
File “”, line 971, in _find_and_load
File “”, line 955, in _find_and_load_unlocked
File “”, line 665, in _load_unlocked
File “”, line 678, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/contrib/sessions/models.py”, line 1, in
from django.contrib.sessions.base_session import (
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/contrib/sessions/base_session.py”, line 26, in
class AbstractBaseSession(models.Model):
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/models/base.py”, line 117, in new
new_class.add_to_class(’_meta’, Options(meta, app_label))
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/models/base.py”, line 321, in add_to_class
value.contribute_to_class(cls, name)
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/models/options.py”, line 204, in contribute_to_class
self.db_table = truncate_name(self.db_table, connection.ops.max_name_length())
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/init.py”, line 28, in getattr
return getattr(connections[DEFAULT_DB_ALIAS], item)
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/utils.py”, line 201, in getitem
backend = load_backend(db[‘ENGINE’])
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/utils.py”, line 110, in load_backend
return import_module(’%s.base’ % backend_name)
File “/usr/lib64/python3.6/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/backends/sqlite3/base.py”, line 66, in
check_sqlite_version()
File “/u01/seafile/seafile-server-8.0.8/seahub/thirdpart/django/db/backends/sqlite3/base.py”, line 63, in check_sqlite_version
raise ImproperlyConfigured(‘SQLite 3.8.3 or later is required (found %s).’ % Database.sqlite_version)
django.core.exceptions.ImproperlyConfigured: SQLite 3.8.3 or later is required (found 3.7.17).
Error:Seahub failed to start.
[21/06 22:56:50] root@sjc51-c01-oem02 /u01/seafile/seafile-server-latest #
[21/06 22:57:10] root@sjc51-c01-oem02 /u01/seafile/seafile-server-latest # sqlite3 –version
SQLite version 3.7.17 2013-05-20 00:56:22