Seafile Server 5.1.4 for Raspberry Pi is ready! 25.07.2016

:pencil2: Note: when upgrade from 5.1.3 or lower version to 5.1.4+, you need to install python-urllib3 manually:

# for Ubuntu
sudo apt-get install  python-urllib3
# for CentOS
sudo yum install python-urllib3

:pushpin: Please remember:

  • Don’t forget to stop Seafile Server before the upgrade (i.e: service seafile-server stop)
  • Don’t forget to change the directory rights of Seafile after unpacking it (i.e: chown -R seafile:nogroup seafile-server-5.1.4 or, another example: sudo chown -R seafile:seafile seafile-server-5.1.4 )
  • Don’t forget to apply the upgrade script/s according your start release && with the properly user which in normal case should be seafile (i.e change to seafile user: su - seafile -s /bin/bash or, another example: sudo su seafile)

Once again, thanks to the developers and Seafile Community

have fun :blush:


Thank you very much for your work!

Hi Jochen,

das Kompliment nehme ich gerne an! Danke Euch auch!

Thanks @jobenvil!
Works as expected as far as I can tell :slight_smile:

Thanks. Works like a charm.

Can anyone post the steps to upgrade to 5.1.4? I followed the directions to install 5.1.3 from another site and have never upgraded a Linux app before. Is it simply the steps listed above?

Yes, basically thats it. As you will only do a maintenance upgrade, you just have to run the
See here

Worked perfect for my upgrading from 5.1.0. I just had to change some directory owners (seafile-data and /tmp/seafile-Folder) because I had started seafile as root before. Without changing you will get broken libraries.


I am running this version now for 2 days on my odroid and I experience a massiv periodically cpu load. It started after the installation of seafile 5.1.4. Before I worked with 5.1.0.

Does anyone else experience this? Expect this, nothing else was changed

interesting, didn’t realized yet about that. Some other clues? Looks like that the peak takes half hour. Isn’t it? In this period should be possible to watch if python/seaf-server is the responsible. So far as I see, this doesn’t happens to me. Can you give more details to the process which saturate CPU?
(Interesting again because I use Seafile on OdroidXU4, like you). I don’t use right now ssl nor webdav.

Upgrade successfull, thanks alot!