Seafile server 7.0 is ready! (Including the CE and PRO edition)

Thanks. It is added now.

That means I cannot generate internal links for pictures as well as office files when I use ONLYOFFICE/Collabora?

For pictures, you can open it in a new tab via the link “Open in New Tab”


For office files using ONLYOFFICE/Collabora, the internal link feature is not available now.

I use a self hosted software to be “not linked” at all to any big cloud provider.
Now you just added a connection, really?

While the files are still local, this still in my view partially defeats the purpose of using Seafile

Please show a connection. I doubt there is one as the log only states the feature has not been configured.

1 Like

Having upgrade warnings Got MySQL warnings when upgraded from 6.3 to 7.0

Have some UI issues after upgrade from 6.3 CE to 7.0.2 CE

ICON Display Issues on Toolbar

SOLVED: thanks to Cisco A simple delete of browser cache solved it. had to do ti on all browsers

1 Like

It is a feature like the OAuth feature via Google and it is turned off by default.


Hi @daniel.pan

I have been testing Seafile Pro 7.0.3 for a week now.

On mobile devices (like iPhone 8) your rewritten UI seems not quite production ready.

I also noticed that saving markdown files after editing them in the WebUI works but users get an error.
I am getting the following error in nginx:

2019/06/21 07:11:11 [error] 22352#22352: *20361 upstream prematurely closed connection while reading upstream, client: XXX.XXX.XXX.XXX, server: XXXXXX, request: "POST /seafhttp/update-api/c0889161-8950-410d-8ea6-9bf6851c6d2c HTTP/2.0", upstream: "", host: "XXXXXXXX", referrer: "https://xxxxxxxxxx/lib/dc26e32b-71b9-4273-bc64-202af6fb6ba8/file/"

Furthermore I am not able to replace an existing file using the WebUI. I am able to upload a file once. If I reupload the same file and choose to replace the first one I am getting the following error.

I am using Firefox for testing. Seafile runs on Debian.

Thanks a lot for your constant development.

1 Like

Found an issue:
Server: CE 7.0.2, Client: WIndows 7.0.0
When i select a library in the client and go to -> view on cloud, the link just takes me to the library overview of all my libraries rather than the library i wanted to see. Url seems to be valid tough.

URL: #common/lib/326c1496-ea18-47ff-bfb4-9f483376fb44/
Looks like a seahub issue

The URL for libraries is changes. We will look into the problem.

Thanks for the new features and Seafile version 7.

Can you please provide change logs with every release? With every update something changes.
Old features are dropped or new added, sometimes without documentation anywhere. Changes like different URLs are no minor change and break many things.
Generally speaking even if this doesn’t apply to 7.0.0:
Minor updates shouldn’t contain any changes at all, they are supposed to fix bugs or close security holes. The community said this several times over the last years, but nothing seems to have changed. This is one of the big points that keeps customers from using Seafile: there seems to be no defined way how you develop Seafile and it seems that you don’t work with any know release cycle standard. It’s more like you release whatever is ready or what you can squeeze into a new release.
I am very sad that there are no changes at all regarding this. Don’t you want to sell more Seafile licences?


After upgrading from 6.x to 7.0.1, seafdav wouldn’t start anymore. The reason was a new dependency, sqlalchemy, which is not documented. Things like this are also hard to debug, because startup errors don’t appear in any log file.

1 Like

The newest version is 7.0.2. 7.0.1 is a beta release.

I know, and I upgraded before 7.0.2 was out. I’m just assuming that the stable release still depends on sqlalchemy and when I checked the manual before writing this post yesterday, I wasn’t able to find a reference to it. It would be great if you could update the manual!


THIS!!! 100%!!!


Thanks for the UI upgrades with v7.

Unfortunately the MEDIA_URL setting is now ignored, which breaks installations that do not run at web root. Seafile now uses the /media folder again instead of the MEDIA_URL setting, breaking existing reverse proxy setups.

Also Avatars are somehow served via HTTP url instead of HTTPS, even if every single root setting is set to HTTPS. This breaks my setup due to restrictive CSP that forbids non-HTTPS items.


Hi @Manuel , have you found any workaround for this?

@jobenvil Yes, I have updated my Nginx config to fix the MEDIA_URL setting temporarly and I am living with the broken avatars as it’s not critical for operation (allowing plain HTTP is a no-go for me)

The avatars problems should have be corrected in 7.0.4.