Seafile server 7.1.3 on Ubuntu 20.04 with Mariadb - no web access

I have a fresh Ubuntu 20.04 server install on a Proxmox VM. I mostly followed the guide here
How To Install Seafile Server On Ubuntu 18.04 LTS
except that it’s for 18.04 so there are a few changes needed for python3 and django captcha

sudo apt -y install python3 python3-pip python3-pil python3-ldap python3-urllib3 libpython3.8 python3-setuptools python3-mysqldb python3-memcache python3-requests ffmpeg

sudo apt install python3-django-captcha

and I followed this guide for mariadb
How To Install MariaDB Server on Ubuntu 20.04

For my ip/domain setting I used:,
I’m using the default ports.

Running start shows the following:

[05/06/20 15:47:34] …/common/session.c(148): using config file /srv/conf/ccnet.conf
Starting seafile server, please wait …
** Message: 15:47:34.623: seafile-controller.c(541): No seafevents.
Seafile server started

And with the additional python3 django captcha install shown above, start shows:

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …
Seahub is started

So to me it all looks fine, except I cannot access the web interface via from my local Windows desktop, chrome says the site can’t be reached. Previously when seahub failed to start I used start-fastcgi to track down the captcha error but now trying the same shows the following:

user@seafile:~$ sudo /srv/seafile/ start-fastcgi
LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub (fastcgi) at …
Unknown command: ‘runfcgi’
Type ‘ help’ for usage.
Error:Seahub failed to start.

Anything obvious I’m missing?

I should mention that I am confused about the nginx portion of the Seafile installation guide I linked to in my first post. Is that required to access Seafile directly on a local computer or only via a domain name and reverse proxy?

fastcgi is not supported anymore!

If you followed the guide then seahub is only available from localhost, read the seafile server.

root@server:~# netstat --listen -n -p | grep :8000
tcp        0      0*               LISTEN      27336/python2.7     
root@server:~# telnet 8000
Connected to
Escape character is '^]'.
GET / HTTP/1.0

HTTP/1.0 302 Found
Server: gunicorn/19.8.1

You access your server through nginx via

That’s what I was starting to suspect. Now, I’m using another nginx reverse proxy server to handle redirects for several servers sharing one public IP. Is it best to still use a local nginx setup on the seafile server or can I just allow direct access to other network devices?

I found that setting host = "" in allows web access from my desktop computer but I’m only barely smart enough to follow a how-to guide so I don’t know if it’s okay to do this.