Seafile Server for Raspberry PI, Model B (Rev 2)


I would like to install Seafile Server on my Raspberry Pi, Model B, Rev 2.
However I do not find a package that is suited to run on that hardware.
The new packages obviously do not run on that hardware (armv6l).
All I found was this:
That however is for Raspbian Jessie - I am running Raspbian Stretch.
Different library versions, and thus that package does not run.

So what could I do?
I am willing to try to build from the sources. However I am in doubt whether I
would succeed, at least with the newest sources in GIT. I reckon too many things will have
changed so it won’t build on Stretch. For instance: Seafile 7.1x uses Python3
whereas Stretch by default still uses Python2. What branches/versions/tags
should I use for being able to build it on Raspbian Stretch?

Easiest of course would be a prepared package.

Ok, I tried it the hard way: I compiled everything on my own using these instructions:

Several packages were missing on my Raspberry PI (ok that wasn’t a real problem).
As a hack I had to create some links in /usr/linclude for “evhtp”.
Finally I got everything compiled.

Installation via “” was without any problems.
Starting everything via
./ start
./ start
worked, too.

However, “seahub” isn’t running after starting it. It obviously silently dies.
A subsequent “seahub stop” gives me:
“Seahub is not running”

The log files don’t give me a clue about what might have gone wrong.
I only see lines such as:
…/common/peer.c(943): Local peer down (ccnet.log)
seafile-controller.c(544): seafdav not enabled. (controller.log)
They don’t seem to be errors for me.

Therefore my (currently) final result on installing Seafile on my Raspberrry PI is:
I give up.

I’m not quite familiar with older Raspberry Pi devices. I began to adopt them as a hobbyist after Raspberry Pi 3 came out.

Run uname -a on the terminal and see what ARM architecture the CPU is using. This is a sample of my output:
Linux raspberrypi 5.10.17-v7l+ #1414 SMP Fri Apr 30 13:20:47 BST 2021 armv7l GNU/Linux

In my case, armv7 is what I’m looking for. With this information, I downloaded the pre-compiled bundle made for my distro and architecture from the official GitHub repo.