Seafile Service does not start after Debian Bullseye updates on RasPi

Hi there,

I am running Seafile Server 9.0.2 CE on Debian Bullseye on Raspberry Pi 3B+.
Everything went fine until I did a reboot after some updates of several Debian packages yesterday.
Now Seafile does not start anymore:

me@raspicloud:~ $ sudo systemctl status seafile.service
● seafile.service - Seafile
Loaded: loaded (/etc/systemd/system/seafile.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2022-07-19 10:25:22 CEST; 31min ago
Process: 519 ExecStart=/home/seafile/seafile-server-latest/ start (code=exited, status=1/FAILURE)
CPU: 209ms

Maybe it has something to do with the DB connection:

● mariadb.service - MariaDB 10.3.24 database server
Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2022-07-19 10:25:19 CEST; 34min ago
Docs: man:mysqld(8)
Process: 384 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
Process: 399 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
Process: 409 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=cd /usr/bin/..; /usr/bin/galera_recovery; [ $? -eq 0 ] && systemctl set-environment _WSREP_START_POSI>
Process: 514 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
Process: 516 ExecStartPost=/etc/mysql/debian-start (code=exited, status=0/SUCCESS)
Main PID: 476 (mysqld)
Status: “Taking your SQL requests now…”
Tasks: 30 (limit: 1717)
CPU: 3.252s
CGroup: /system.slice/mariadb.service
└─476 /usr/sbin/mysqld

Jul 19 10:25:18 raspicloud mysqld[476]: 2022-07-19 10:25:18 0 [Warning] Could not increase number of max_open_files to more than 16384 (request: 32186)
Jul 19 10:25:19 raspicloud systemd[1]: Started MariaDB 10.3.24 database server.
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[518]: Upgrading MySQL tables if necessary.
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[522]: Looking for ‘mysql’ as: /usr/bin/mysql
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[522]: Looking for ‘mysqlcheck’ as: /usr/bin/mysqlcheck
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[522]: Version check failed. Got the following error when calling the ‘mysql’ command line client
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[522]: ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[522]: FATAL ERROR: Upgrade failed
Jul 19 10:25:19 raspicloud /etc/mysql/debian-start[553]: Checking for insecure root accounts.
Jul 19 10:25:19 raspicloud debian-start[556]: ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

I tried to set the root PW for the DB directly in /etc/mysql/debian.cnf (“DO NOT TOUCH!”), but it doesnt change anything.

Can anybody help me please.


It sounds like a problem with dependencies. Check your prerequisites as per Installation with MySQL - Seafile Admin Manual.

Then you can check if you can connect directly with MySQL/MariaDB:

  • cat /opt/seafile/conf/
  • Copy mysql password in clipboard
  • mysql -u seafile -p
  • Paste password when prompted

If this connection fails, you have a credential problem.

I connect to the DB without problems, I even successfully tried changing my password. For me it seems that Debian has something like a new start script that try to connect to the DB without password?!
As I said before, the whole system was up and running until some new packages arrived and it was restarted.