SeafilePro App - "no available certificates"

Recently got logged out of seafile on my iOS device - when trying to log back in I receive the error “No Certificates Available”

My HTTPS/SSL seems to look good, valid cert and all that and it works fine from the web client. I tried disabling SSL but still no connection. Not really sure what changed or what’s going wrong here.

I use Cloudflare for my DNS however the problem doesn’t seem to lie here either as far as I can tell.

Funny enough now too when I try to use the app on my mac it also doesn’t work anymore. Really unsure what to make of this.

I’ve tried a bunch of stuff:

  • downgrading seafile docker image
  • installing seafile pro (only one user so it’s free)
  • disabling https verification
  • all sorts of playing with https/ssl settings in cloudflare
  • much more more nonsense

Worth noting maybe too this is on a subdomain of a domain I use for other sites as well - i.e., for Seafile and for a website.

Any advice would be really helpful, I really relied on the camera upload feature and will be pretty upset without it which can’t be emulated through the web UI.

Really getting frustrated with this, love Seafile but not sure how to handle this going forward. Dealbreaker if I can’t access the app from my phone.

If it’s meaningful as well this is a self hosted instance via Docker.

Screen Shot 2023-08-13 at 11.07.41 PM

Thanks in advance!

You said that you are getting the same error on your Mac. Have you tried analyzing the Seafile/Seadrive app’s logs ?