Seahub failed to start due _msql error

Hello guys,

I have installed Seafile Server 9.0.2 for Raspberry Pi on my Raspberry 4 (Bullseye 64 bit). The installation went without any problems. The Seafile server starts without any problem. Initially also the Seahub server started. But then it quits without leaving a single log entry. I only get an error message in journalctl:

Jun 02 11:53:58 galaxia systemd[1]: Starting Seahub…
Jun 02 11:53:58 galaxia[24067]: Starting seahub at port 8000 …
Jun 02 11:54:04 galaxia[24067]: Seahub is started
Jun 02 11:54:04 galaxia[24067]: Done.
Jun 02 11:54:04 galaxia systemd[1]: Started Seahub.
Jun 02 11:54:06 galaxia systemd[1]: seahub.service: Main process exited, code=exited, status=1/FAILURE
Jun 02 11:54:06 galaxia systemd[1]: seahub.service: Failed with result ‘exit-code’.

I have no idea what else to do. Also the usual search in the net did not give any result.

Does anyone have any ideas?


It still does not run…

In the meantime I found more with the command:

./ start-fastcgi

I get the message:

File “/home/seafile/seafile-server-9.0.2/seahub/thirdpart/MySQLdb/”, line 24, in version_info, _mysql.version_info, _mysql.file
NameError: name ‘_mysql’ is not defined
Error:Seahub failed to start.

Everything I have found on the forums concerns older versions and has not solved the problem.

I have found the solution to the problem. It was my mistake.

I use a Raspberry Pi4 with Bullseye OS in the 64 bit varriante. For the installation I used one of the many and good tutorials on the internet. The described exactly how to do the installation with database server. Because I wanted to use my MaraiDB right away. What I simply overlooked all the time was that the instructions install the 32-bit varriante. When I then used the correct 64-bit variant, the installation worked smoothly.