Seahub failed to start error

Recently I have been setting up a Seafile home server, So I used the Digital Ocean Tutorial (Cannot provide a link), And everything went relatively smoothly until I got to the part where I had to run Seahub where I got this error.

Starting seahub at port 8000 …
Error:Seahub failed to start.
Please try to run “./ start” again

I checked the log file for seahub but it was completely empty, so being new to seafile I am hoping that someone here knows what is wrong. Thank you!

You can also modify conf/gunicorn.conf , change daemon = True to daemon = False , then run ./ again. If there are missing Python dependencies, the error will be reported in the terminal.

Hey I did that and found that I was missing a dependency which after installing it I no longer got an error and it ran. But now I have a new issue which is that I cannot access the website, I checked the firewall and even tried turning it off to test if it was the issue but no luck. I also tried fully reinstalling Seafile but I keep running into the same issue.

I found that after running a wget command the website is accessible locally from the server but when I try to connect using another computer on the same network I get no response. Output to the wget command:

–2023-06-20 19:19:53-- localhost:8000/
Resolving localhost (localhost)… ::1,
Connecting to localhost (localhost)|::1|:8000… failed: Connection refused.
Connecting to localhost (localhost)||:8000… connected.
HTTP request sent, awaiting response… 302 Found
Location: /accounts/login/?next=/ [following]
–2023-06-20 19:19:53-- localhost:8000/accounts/login/?next=/
Connecting to localhost (localhost)||:8000… connected.
HTTP request sent, awaiting response… 200 OK
Length: 12287 (12K) [text/html]
Saving to: ‘index.html’

index.html 100%[====================================================>] 12.00K --.-KB/s in 0s

2023-06-20 19:19:53 (458 MB/s) - ‘index.html’ saved [12287/12287]
(Note: I removed the http:// from every limk)